在线检测未来函数

通达信极品RSI指标公式

来源:Internet,编辑:股旁网,2011-07-04

N1:=5;N2:=10;
LC := REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLOR9900FF;
RSI2:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100,COLORYELLOW;
强弱分界:50,COLORFFFFCC;
坐标线:0,COLORFFFF33;20,COLOR00FF00; 80,COLOR0000FF;100,COLORFFFF33;
{趋势买卖}
V1:=LLV(LOW,10);
V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
{www.gUPang.com 股旁网_最新股票指标公式}
买入:STICKLINE(CROSS(价位线,0.3),50,5,2,0),COLOR00CCFF,LINETHICK1;
STICKLINE(CROSS(价位线,0.3),30,5,2,0),COLORRED,LINETHICK1;
卖出:STICKLINE(CROSS(3.5,价位线),60,100,2,0),COLORRED,LINETHICK1;
STICKLINE(CROSS(3.5,价位线),80,100,2,0),COLORFF9900,LINETHICK1;
DRAWTEXT(CROSS(价位线,0.3),45,' 买'),COLORFFAA66;
DRAWTEXT(CROSS(3.5,价位线),75,' 卖'),COLORFFFFCC;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);

通达信极品RSI指标公式

 

相关文章