在线检测未来函数

大智慧均线速度指标公式

来源:Internet,编辑:股旁网,2011-08-16

P1:=5;P2:=30;
A1:=MA(CLOSE,P1);
A2:=REF(A1,1);
J1:(A1-A2)/A2*100;
MJ1:ma(J1,3);
A3:=MA(CLOSE,P2);
A4:=REF(A3,1);
J2:(A3-A4)/A4*100;
MJ2:=MA(J2,10);
A5:=ma(c,10);
A6:=ref(A5,1);
J3:=(A5-A6)/A6*100;
Mj3:=ma(j3,5);
{向上拐点:if(count(cross(j1,0),3)>=1 and mj1>mj3 and mj3>ref(mj3,1) and J3>=0 and J1>ref(j1,1),5,0) ,colorred,linethick2;
向下拐点:if(cross(0,j1)>=1 and mJ3<ref(mj3,1) and mJ2<ref(mj2,2) and mJ3<mJ2,-5,0),colorgreen,linethick2;}
0,COLORwhite;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
STICKLINE(J1>0 AND J2>0,J1,0,2,0),COLORRED;
STICKLINE(J1<0 AND J2>0,0,J1,2,0),COLORYELLOW;
STICKLINE(J1>0 AND J2<0,J1,0,2,0),COLORMAGENTA;
STICKLINE(J1<0 AND J2<0,0,J1,2,0),COLORGREEN;
DRAWICON(CROSS(J1,mJ1) AND count(mj1<-1,3)>=1 ,J1*1.5,1);
DRAWICON(CROSS(mJ1,J1) AND count(mj1>1,3)>=1,J1*1.8,2);

大智慧均线速度指标公式

 

相关文章