在线检测未来函数

通达信MACD绝代双娇指标公式

来源:Internet,编辑:股旁网,2011-09-22

SQX:=(C-MA(CLOSE,13))*100;
DIF:EMA(MA(SQX,7),1),LINETHICK1;
DEA:EMA(DIF,7),LINETHICK1;
MACD: (DIF-DEA)*2,COLORSTICK;
红柱持股:IF(MACD>REF(MACD,1),MACD,DRAWNULL),STICK,COLORRED,LINETHICK1;
绿柱持币:IF(MACD<REF(MACD,1),MACD,DRAWNULL),STICK,COLORLIBLUE,LINETHICK2;
低位金叉:IF(CROSS(DIF,DEA) AND DIF<-0.1,0.3,0),COLORYELLOW,POINTDOT;
STICKLINE(低位金叉,0,10,8,1),COLORYELLOW;
DRAWICON(低位金叉,0.3,1);
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORFF00FF,POINTDOT;
STICKLINE(二次金叉,25,15,8,1),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),0.1,0),COLORRED,POINTDOT;
STICKLINE(底背离,40,30,8,1),COLORRED;
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF),COLORGREEN;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN;
A3:=CROSS(DIF,DEA) AND DEA<0;
零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT;
STICKLINE(零下二次金叉,45,55,8,1),COLORWHITE;
金叉:DRAWICON(CROSS(DIF,DEA),DIF,1);
死叉:DRAWICON(CROSS(DEA,DIF),DIF,2);

通达信MACD绝代双娇指标公式

 

相关文章