在线检测未来函数

通达信MACD+KDJ+RSI主图指标公式

来源:Internet,编辑:股旁网,2011-10-11

DE:=CONST(LLV(L,90));
JI:=CONST(HHV(H,90))-DE;
DE_K:=DE+JI/3*2;
JI_K:=JI/2;
L_00:=DE_K;
L_20:=JI_K/5+DE_K;
L_80:=JI_K*4/5+DE_K;
L_100:=JI_K+DE_K;
L_5:=L_100-L_00;
L_50:=(L_00+L_100)/2;
DRAWBAND(L_100,RGB(00,180,00),L_00,DRAWNULL);
DRAWBAND(L_80,RGB(00,150,00),L_00,DRAWNULL);
DRAWBAND(L_50,RGB(00,100,00),L_00,DRAWNULL);
DRAWBAND(L_20,RGB(00,55,00),L_00,DRAWNULL);
DRAWTEXT(CURRBARSCOUNT=200/2,L_100-(L_100*0.03),'====【传统指标MACDKDJRSI.编制】===='),COLORWHITE;
DRAWTEXT(ISLASTBAR,L_100,'100'),COLORRED;
DRAWTEXT(ISLASTBAR,L_80,' 80'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,L_50,' 50'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,L_20,' 20'),COLOR00FF00;
DRAWTEXT(ISLASTBAR,L_00,' 0'),COLORWHITE;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
DRAWBAND((RSI1/100-0.5)*L_5/1+L_50,RGB(255,50,50),(RSI2/100-0.5)*L_5/1+L_50,RGB(00,180,80));
DRAWICON(CROSS(80,RSI1),L_100,15);
DRAWICON(CROSS(RSI1,20),L_00,23);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
DE_A:=CONST(LLV(RSV,90));
DD_A:=CONST(HHV(RSV,90))-DE_A;
R:=(RSV-DE_A)/DD_A;
RSV1:=R*JI_K+DE_K;
K:SMA(RSV1,3,1),COLORFFFFFF;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORFF00FF;
DE_M:DE+JI/3,COLORRED;
JI_M:=JI/2;
KDL:=CONST(LLV(EMA(C,26),90));
KDH:=CONST(HHV(EMA(C,26),90))-KDL;
R_K1:=(EMA(C,12)-KDL)/KDH;
R_K2:=(EMA(C,26)-KDL)/KDH;
DIF:(R_K1-R_K2)*JI*1.5+DE_M,COLOR00FF00;
DEA:EMA(DIF,9),COLORLIBLUE;
MACD:=(DIF-DEA)*2+DE_M;
STICKLINE(MACD<REF(MACD,1)AND MACD>DE_M AND CROSS(K,J),DE_M,MACD,2.8,0),COLORFF3300;
STICKLINE(MACD>REF(MACD,1)AND MACD<DE_M AND CROSS(J,K),DE_M,MACD,2.8,0),COLORRED;
STICKLINE(MACD<DEA AND MACD>DE_M AND CROSS(D,K),DE_M,MACD,2.8,0),COLOR00FF00;
DRAWKLINE(H,O,L,C);
STICKLINE(MACD>=DE_M,MACD,DE_M,0,0),COLORRED;
D_1:=MACD>H AND H>=DE_M AND DE_M>=L;
D_2:=MACD>H AND H>=L AND L>DE_M;
D_3:=H>MACD AND MACD>=L AND L>DE_M;
D_4:=H>MACD AND MACD>DE_M AND DE_M>=L;
STICKLINE(D_1>0,H,DE_M,0,0),COLORYELLOW;
STICKLINE(D_2,H,L,0,0),COLORYELLOW;
STICKLINE(D_3,MACD,L,0,0),COLORYELLOW;
STICKLINE(D_4,MACD,DE_M,0,0),COLORYELLOW;
D_5:=MACD<L AND L<=DE_M AND DE_M<=H;
D_6:=MACD<L AND H<DE_M;
D_7:=L<MACD AND MACD<=H AND H<DE_M;
D_8:=L<MACD AND MACD<DE_M AND DE_M<=H;
{www.gUPaNg.com 股旁网_最新股票指标公式}
STICKLINE(MACD<DE_M,DE_M,MACD,0,0),COLOR009900;{LIBLUE}
STICKLINE(D_5,DE_M,L,0,0),COLORYELLOW;
STICKLINE(D_6,H,L,0,0),COLORYELLOW;
STICKLINE(D_7,H,MACD,0,0),COLORYELLOW;
STICKLINE(D_8,DE_M,MACD,0,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR,DE_M,' 零轴线'),COLORWHITE;
DRAWBAND(MA(DIF,2),RGB(255,255,255),DIF,RGB(455,0,455));
DEA,COLORYELLOW;
{BS主图}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
卖:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWICON(FILTER(卖=1,1),HIGH*1.01,8);
买入:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLOR0000FF;
MA1:=SMA(C,3,1),COLORGREEN;
DRAWICON(CROSS(MA1,买入),L*0.99,7);

通达信MACD+KDJ+RSI主图指标公式

 

相关文章