在线检测未来函数

大智慧猛虎掘金主图指标公式

来源:Internet,编辑:股旁网,2011-11-02

QIXIAN:='指标简要说明: ';
DRAWTEXTREL(0,0,QIXIAN+' --短线中线的转换,【持股线】是小趋势,【波段线】是大趋势。'),color808080;
mms:=ma(sma((l+h+2*c)/4-ref((l+h+2*c)/4,1),5,1)/sma(abs((l+h+2*c)/4-ref((l+h+2*c)/4,1)),5,1)*100,1)+50;
g1:=if(-mms>95,0,20);
uoo:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 and g1)+1);
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
KS1:=if(BARSCOUNT(c)=1,c/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:= - 100 * (趋势线 - CLOSE) / 趋势线;
AC:=(EMA(AA,5) );
SSL:=EMA(CLOSE,3);
MMV:=ma(close,24);
MM:=MMV;
STICKLINE(((SSL > MM) ),SSL,MM,0.1,0),colorred;
波段线:MMV,LINETHICK2,COLORMAGENTA;
VAR2Y:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);
VAR4Y:=REF(CLOSE,1);
VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);
VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE - VAR4Y)),12,1)) * 100);
VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE - VAR4Y)),24,1)) * 100);
VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);
VAR9Y:=SMA(VAR8Y,3,1);
VARAY:=SMA(VAR9Y,3,1);
VARBY:=((3 * VAR9Y) - (2 * VARAY));
VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));
VARDY:=((100 - CROSS(76,VAR5Y)) AND (VAR3Y > (5 * 20)));
DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y > 5)) ),(HIGH * 1.01),5),colorFFFFFF;
VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 - 30))) AND (VAR2Y > 3)) * 30);
VARFY:= - ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26))) * 10);
DRAWICON((CROSS(VARFY,(0 - 9))),(LOW * 0.998),4);
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) * 4)));
上开:=o;
上收:=c;
上高:=h;
上低:=l;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,3);
B:REF(A,1),POINTDOT,COLORYELLOW;
持股线:A,COLORYELLOW,LINETHICK1;
STICKLINE(((SSL < MM) ),波段线,持股线,0.1,0),COLOrffbbff;
FILLRGN(a,b,A>=B),colorred;
FILLRGN(a,b,A<B),colorgreen;
选手A:=MA(上收,3);
阻力线A:=MA(REF(HHV(上收,6),1),3);
支撑线A:=MA(REF(LLV(上收,3),1),3);
t1:=MA(上收,20)>=REF(MA(上收,20),1);
t2:=CROSS(选手A,支撑线A) AND 阻力线A/支撑线A>100/100 AND t1;
t3:=CROSS(阻力线A,选手A) AND 阻力线A/支撑线A>100/100;
选手:=MA(上收,2);
阻力线:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
支撑线:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
t4:=CROSS(选手,支撑线) AND 阻力线/支撑线>110/100;
t5:=CROSS(阻力线,选手) AND 阻力线/支撑线>110/100;
Var1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=SMA(Var3,3,1);
{K线}
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLORB0B0FF;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),colorFFAA00;
STICKLINE(C<=O,C,O,4,0),COLORffbbff;
STICKLINE(C<=O,C,O,2,0),COLORffbbff;
STICKLINE(C<=O,H,L,0,0),COLORffbbff;
{K线卖提示}
Qc0:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
stickline(Qc0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,open,close,3,0),COLOR3366FF;
stickline(Qc0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,H,L,0.5,0),COLOR3366FF;
{K线买提示}
Var111:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VarD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VarE :=REF(VarD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarF :=REF(VarE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var10 :=REF(VarF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var11:=REF(Var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var12:=REF(Var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var13:=REF(Var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var14:=REF(Var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var15:=REF(Var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var16:=REF(Var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var17:=REF(Var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var18:=REF(Var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var19:=REF(VarD OR VarE OR VarF OR Var10 OR Var11 OR Var12 OR Var13 OR Var14 OR Var15 OR Var16 OR Var17 OR Var18,1) AND Var1;
趋势线1:=FORCAST(CLOSE,7);
Fk:=100*(C-REF(C,1))/REF(C,1);
pk1:=IF(C<REF(O,1) AND fk<0,1,0);
pk2:=IF(C<REF(O,2) AND fk<0,1,0);
stickline((Pk1=0 AND REF(Pk1,1)=1 AND Pk2=0 AND REF(Pk2,1)=1)AND(趋势线1>REF(趋势线1,1)OR 持股线>REF(持股线,1)),open,CLOSE,3,0),COLORred;
stickline((Pk1=0 AND REF(Pk1,1)=1 AND Pk2=0 AND REF(Pk2,1)=1)AND(趋势线1>REF(趋势线1,1)OR 持股线>REF(持股线,1)),H,L,0.5,0),COLORred;
{www.gUPaNg.com 股旁网_最新股票指标公式}
pk3:=(((CLOSE / OPEN) > 1.04) AND (CLOSE <(SMA(HIGH,21,2) * 1.05))) AND ((CLOSE - REF(CLOSE,1)) > 0);
STICKLINE(pk3 AND(趋势线1>REF(趋势线1,1)OR 持股线>REF(持股线,1)),CLOSE,OPEN,3,0),COLORred;
STICKLINE(pk3 AND(趋势线1>REF(趋势线1,1)OR 持股线>REF(持股线,1)),H,L,0.5,0),COLORred;
STICKLINE(Var19 AND(趋势线>REF(趋势线1,1)OR 持股线>REF(持股线,1)),CLOSE,OPEN,3,0),COLORred;
STICKLINE(Var19 AND(趋势线>REF(趋势线1,1)OR 持股线>REF(持股线,1)),H,L,0.5,0),COLORred;
买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
STICKLINE(买进条件 AND 波段线>持股线 AND 持股线>REF(持股线,1),L,L*0.998,7,0),COLORWHITE;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
DRAWTEXT(CROSS(买线,卖线)AND 阻力线>=REF(阻力线,1),支撑线,'★'),COLOR00FFFF;
stickline(cross(买线,卖线),open,close,3,0),color00ffff;
stickline(cross(买线,卖线),h,l,0.5,0),color00ffff;

大智慧猛虎掘金主图指标公式

 

相关文章