在线检测未来函数

通达信一根线搞定DMI指标公式

来源:Internet,编辑:股旁网,2011-12-08

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:= DMP*100/MTR;
MDI:= DMM*100/MTR;
DM:=PDI-MDI,NODRAW;
TRR1:=EMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),14);
DMP1:=EMA(IF(HD>0 && HD>LD,HD,0),14);
DMM1:=EMA(IF(LD>0 && LD>HD,LD,0),14);
ADX0:=EMA((DMP1-DMM1)/(DMP1+DMM1)*100,6);
ADXR0:=EMA(ADX0,6);
PDI1:=DMP1/TRR1*100;
MDI1:=DMM1/TRR1*100;
DM1:=PDI1-MDI1;
AAJ:=(3*ADX0-2*ADXR0);
MAAD:=(ADX0-ADXR0),NODRAW;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORFF00FF;{www.gUPaNg.com 股旁网_最新股票指标公式}
ADXR:EXPMEMA(ADX,6),POINTDOT,LINETHICK7,COLORGREEN;
IF(DM>0,ADXR,DRAWNULL),POINTDOT,LINETHICK7,COLORRED;
助涨:DRAWICON(DM>0 AND ADX>ADXR AND ADX>20,ADXR,15);
助跌:DRAWICON(DM<0 AND ADX>ADXR AND ADX>20,ADXR,12);
DRAWICON(CROSS(ADXR0,ADX0) AND ADXR0>60 ,ADXR*1.2,8);
DRAWICON(CROSS(ADXR0,ADX0) AND ADXR0<60 ,ADXR*1.4,2);
20,COLORYELLOW,DOTLINE;
60,COLORGREEN,DOTLINE;

通达信一根线搞定DMI指标公式

 

相关文章