在线检测未来函数

通达信涨停五基因指标公式

来源:Internet,编辑:股旁网,2011-12-15

{1.百日低量群}
百日地量:= V=LLV(V,100) AND V>0;
倍量:= VOL>=REF(V,1)*1.9 AND C>REF(C,1);
地量又倍量:COUNT(百日地量,5)>=1 AND COUNT(倍量,1)>=1;{2.倍量过左峰}
N:=20;
左峰高:=REF(HHV(C,N),1);
倍量过左:REF(COUNT(C<左峰高,2)=2,1) AND C>左峰高 AND C>O
AND VOL/REF(VOL,1)>=1.9;{3.回踩黄金线}
{1.黄金柱}
JJ:=(3*C+H+L+O)/6;
VAR1:=DMA(JJ,0.2);
{VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)
+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;}
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,3);
黄金线:=REF(LOW,BARSLAST(LJL));
黄金柱:=FILTER(TJ1,3);
{2.倍量过左峰}
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
{倍量:=VOL/REF(VOL,1)>=2 AND COUNT(CLOSE>OPEN,1) OR LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>=2;}
突破前高:=CROSS(C,前高);
倍量过左峰:= 突破前高 AND 倍量;
{3.凹口起柱}
T7:=REF(VOL,6)/REF(VOL,7)>=2;
T6:=REF(VOL,5)/REF(VOL,6)>=2;
T5:=REF(VOL,5)/REF(VOL,4)>=1.5;
T4:=REF(VOL,4)/REF(VOL,3)>=1.5;
T3:=REF(VOL,2)/REF(VOL,3)>=1.5;
T1:=V/REF(VOL,1)>2;
T0:=C>O AND C>REF(C,1);
凹口起柱:= T7 AND T1 AND T0
OR T6 AND T1 AND T0
OR T5 AND T1 AND T0
OR T4 AND T1 AND T0
OR T3 AND T1 AND T0 ;
{凹口起柱}
AKQZ:= 黄金柱 AND 凹口起柱;
{4.前高低位}
X:=21;
TTY:=H;
AAT:=REF(TTY,X)=HHV(TTY,2*X+1);
BBT:=FILTER(AAT,X);
CCT:=BACKSET(BBT,X+1);
HD10T:=FILTER(CCT,X);
前期高位:=REF(H,BARSLAST(HD10T));
{突破前高}
TPQG:= 黄金柱 AND 倍量过左峰 AND C>前期高位;
{选股}
回踩黄金线: (COUNT(TPQG,10) OR COUNT(AKQZ,10))
AND COUNT(CROSS(黄金线*1.01,L),3)>0 AND L>=黄金线
AND C>REF(C,1) AND REF(C,2)>REF(C,1) AND COUNT(LJL,3)=0;{5.长阴短柱}
长阴短柱: C/REF(C,1)<0.95 AND V<HHV(V,30)/1.9;
{6.1 底同向精准}
NN:=3;
LL0:=0;
L0:=LL0/100;
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线:=L1 OR L2 OR L3 OR L4 OR L5;
底精准: FILTER(精准线,NN),COLORCYAN;
{www.gUPaNg.com 股旁网_最新股票指标公式}
{6.2 异向并肩精准线}
异向并肩精准: MIN(O,C)=REF(MAX(O,C),1) ;
{4.咬住峰顶线}
FDX:=PEAK(1,10,1);{REF(HHV(H,60),5)};{上一波峰值}
TJ:=BETWEEN(MA(H,3),FDX*0.997,FDX*1.02);
咬住峰顶线: COUNT(TJ,3)>=2,COLORRED;

通达信涨停五基因指标公式

 

相关文章