在线检测未来函数

通达信趋势顶底+AROON指标公式

来源:Internet,编辑:股旁网,2012-01-11

A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:A+100,COLOR0000FF;
中期线:D+100,COLORYELLOW,NODRAW;
DRAWBAND(中期线,RGB(150,0,100),长期线,RGB(0,50,100));
短期线:B+100,COLOR00FF00;
{www.gUPaNg.com 股旁网_最新股票指标公式}
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
顶部区域:=(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4;
顶部:=FILTER(顶部区域,4);
底部区域:=(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ,COLORGREEN;
清仓:IF( {见顶 OR} 顶部,110,100),COLORFFCC00,LINETHICK2;
关注:IF( 底部区域,20,0),COLOR9933FF,NODRAW;
STICKLINE(关注,105,-5,0,0 ),COLOR9933FF;
低位金叉:50*(长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 )),COLORRED,NODRAW;
STICKLINE( 低位金叉,0,-5,5,0 ),COLOR0000FF;
{AROON}
熊:100-(34-LLVBARS(L,34+1))/34*100,COLORFFFF00,LINETHICK2;
牛:(34-HHVBARS(H,34+1))/34*100,COLOR7F00FF,LINETHICK2;
STICKLINE(80,80,80,10,0),COLORFFFFFF;
STICKLINE(50,50,50,10,0),COLORFFFFFF;
STICKLINE(20,20,20,10,0),COLORFFFFFF;
STICKLINE(20,0,0,10,0),COLORFFCC00;

通达信趋势顶底+AROON指标公式

 

相关文章