在线检测未来函数

大智慧BOLL+MACD主图指标公式

来源:Internet,编辑:股旁网,2012-01-12

input:n(26,5,300),p(2,0.1,10);
MA13:MA(C,13),COLORFF9900,DOTLINE;
MID : MA(CLOSE,N),DOTLINE;
UPPER: MID + P*STD(CLOSE,N),DOTLINE;
LOWER: MID - P*STD(CLOSE,N),DOTLINE;
X:=BARSLAST(DISPSTATUS=1)+1;
E:=llvall(llv(l,x))*0.95;
DIFF :EMA( EMA(CLOSE,12) - EMA(CLOSE,26),3),COLOR0000FF,LINETHICK0;
DEA : EMA(DIFF,9),COLOR00FF00,LINETHICK0;
MACD : 2*(DIFF-DEA),LINETHICK0;
STICKLINE(MACD>0,E+MACD*3,E,18,0),Color0000FF;
STICKLINE(MACD<0,E+MACD,E,1,0),Color00FF00;
DRAWGBK(MACD>0 ,STRIP(RGB(0,0,255),RGB(140,0,80),0)),LAYER0;
VERTLINE(CROSS(REF(WMA(C,13),1),WMA(C,13)) AND MACD>0 and MA13>MID,2),LAYER0,COLOR00FFff;
PARTLINE(UPPER ,UPPER and MACD>0,rgb(255,120,0)),LINETHICK3,LAYER0;
PARTLINE(MID ,MID and MACD>0,rgb(0,255,0)),LINETHICK3,LAYER0;
PARTLINE(MA13 ,MA13 and MACD>0,rgb(255,255,0)),LINETHICK3,LAYER0;
{www.gUPaNg.com 股旁网_最新股票指标公式}
PK:=CROSS(0,MACD) AND MACD<0;
DRAWTEXT(PK,LOWER*0.999,'●'),LAYER3,ALIGN1,COLOR0000FF,LINETHICK2;
DRAWTEXT(PK,LOWER*0.981,'【别】'),LAYER0,ALIGN1,COLOR00FFFF,LINETHICK1;
DRAWTEXT(PK,LOWER*0.963,'【坐】'),LAYER0,ALIGN1,COLOR00FFCC,LINETHICK1;
DRAWTEXT(PK,LOWER*0.946,'【过】'),LAYER0,ALIGN1,COLOR00FFAA,LINETHICK1;
DRAWTEXT(PK,LOWER*0.929,'【山】'),LAYER0,ALIGN1,COLOR00FF77,LINETHICK1;
DRAWTEXT(PK,LOWER*0.912,'【车】'),LAYER0,ALIGN1,COLOR00FF00,LINETHICK1;

大智慧BOLL+MACD主图指标公式

 

相关文章