在线检测未来函数

通达信MACD+KDJ+BOLL+量比换手指标公式

来源:Internet,编辑:股旁网,2012-01-22

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK2;
K:SMA(RSV,3,1),LINETHICK1;
D:SMA(K,3,1),LINETHICK1;
J:=3*K-2*D,COLORFF00FF,LINETHICK1;
IF(K<15,K,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,40,'KDJ躺底吸纳');
{MACD部分}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD2:=(DIF-DEA)*200,COLORSTICK;
STICKLINE(DIF>DEA,-10,-15,10,0),COLORRED;
STICKLINE(DIF<DEA,-10,-15,10,1),COLORGREEN;
{www.gupang.com 股旁网_股票通达信指标公式}
DRAWTEXT(CURRBARSCOUNT=1,-10,'MACD红持绿退');
{换手部分}
HS5:=MA(HSL,5);
HS60:=MA(HSL,60);
STICKLINE(HS5>HS60,100,105,10,0),COLORMAGENTA;
STICKLINE(HS5<HS60,100,105,10,1),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,105,'HSL红高换手');
DRAWICON(CROSS(K,D) AND MACD>0,K-5,1);
{量比部分}
LBB:=V/(REF(V,15)/5);
MA120:=MA(LBB,120)/10;
DIF1:=EMA(LBB,30)-EMA(LBB,60);
DEA1:=EMA(DIF1,15);
STICKLINE(DIF1>DEA1,90,95,10,0),COLORRED;
STICKLINE(DIF1<DEA1,90,95,10,1),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,90,'量比红进绿退');
{布林部分}
BOLL:=MA(CLOSE,20);
UB:=BOLL+2*STD(CLOSE,20);
LB:=BOLL-2*STD(CLOSE,20);
STICKLINE(LB>C,-20,-25,10,0),COLORMAGENTA;
STICKLINE(LB<C,-20,-25,10,1),COLORWHITE;
STICKLINE(C>UB,-20,-25,10,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,-20,'BOLL红底绿高');

通达信MACD+KDJ+BOLL+量比换手指标公式

 

相关文章