在线检测未来函数

通达信股市大资金主图指标公式

来源:Internet,编辑:股旁网,2012-02-03

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
MA250:MA(CLOSE,250);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW*0.95,'←播种'),COLORRED,LINETHICK2;
DRAWICON(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW*0.95,17);
VAR1:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
DRAWTEXT(VAR1>90,LOW*0.92,'←追肥'),COLORFF00FF;
DRAWICON(VAR1>90,LOW*0.92,25);
VAR2:=(POW(MA(CLOSE,5),2)+MA(CLOSE,5));
VAR3:=(POW(MA(LOW,5),2)+MA(LOW,5));
VAR4:=(POW(MA(HIGH,5),2)+MA(HIGH,5));
VAR5:=(((((VAR2-LLV(VAR3,64))/(HHV(VAR4,64)-LLV(VAR3,64)))*150)+65)-10);
VAR6:=((SMA(VAR5,3,1)*1.5)-100);
VAR7:=SMA(VAR6,3,1);
VAR8:=((3*VAR6)-(2*VAR7));
VAR9:=(((HIGH+LOW)+(CLOSE*2))/4);
VAR10:=EMA(VAR9,13);
VAR11:=STD(VAR9,13);
VAR12:=(((VAR9-VAR10)*100)/VAR11);
VAR13:=EMA(VAR12,5);
VAR15:=((EMA(VAR13,13)+200)-100);
VAR16:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
DRAWTEXT(FILTER(VAR16<-9 AND VAR16>REF(VAR16,1),18),L*0.9,'←抢播♂'),COLORRED,LINETHICK2;
DRAWICON(FILTER(VAR16<-9 AND VAR16>REF(VAR16,1),18),L*0.9,1);
VAR17:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR18:=VAR8<REF(VAR17,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
资金:=(VAR18 AND COUNT(VAR18,30)=1);
DRAWTEXT(大资金,LOW*0.85,'▲大资金');
{季节变化}
AA:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B11:=L-A0;
STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B11,B11-1.5*A0,2,0),COLORF00FF0;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B11-1*A0,'季节变化'),COLORLIGREEN;
{大笔出货}
VAR22:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR23:=(HIGH+LOW+CLOSE)/3;
VAR24:=(VAR23-MA(VAR23,14))/(0.015*AVEDEV(VAR23,14));
VAR25:=(VAR23-MA(VAR23,70))/(0.015*AVEDEV(VAR23,70));
VAR26:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR27:=100-ABS(VAR26);
VAR28:=IF(VAR27<90,VAR27,100);
VAR29:=IF(VAR22>0,VAR22,0);
VAR30:=IF(VAR25>=200 AND VAR24>=150,15,IF(VAR25<=-200 AND VAR24<=-150,-15,VAR15))+60;
VAR31:=VAR29>48 AND VAR30>60 AND VAR28<100;
DRAWTEXT(VAR31 AND COUNT(VAR31,30)=1,HIGH*1.02,'大笔出货'),LINETHICK1,COLORFFCC66;
XXS:=MA(HIGH,5)*(1+5/100);
DRAWTEXT(CROSS(XXS,C),H,'←收割'),COLORGREEN,LINETHICK1;
DRAWICON(CROSS(XXS,C),H,9);
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
鼠:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
DRAWTEXT(鼠,(LOW* 0.99),'←鼠'),COLOR40CCFF;
DRAWICON(鼠,(LOW* 0.99),23);
VAR013:=IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL);
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT((IF(CLOSE>MA(CLOSE,13) AND OPEN<CLOSE,-0.1,0))AND((C-REF(C,1))/(REF(C,1))>0.061)AND (MA(CLOSE,13)=VAR013) AND (MA(CLOSE,1),MA(CLOSE,13)) AND (VOL>REF(HHV(VOL,3),1)*2),L*0.9,'主力介入'),COLORRED;

通达信股市大资金主图指标公式

 

相关文章