在线检测未来函数

同花顺S散户原版指标公式

来源:Internet,编辑:股旁网,2012-02-05

N:=13;N1:=75;M:=14;M1:=5;
Var1:=1;
Var2:=3*SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,20,1),15,1);
Var3:=3*SMA((OPEN-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,20,1),15,1);
Var4:=0-Var3;
Var5:=0-Var2;
STICKLINE(Var5< REF(Var4,1),(-1)*Var5,(-1)*Var4,6,1), , COLORRED;
Var6:=MA(Var4,3);
STICKLINE((-1)*Var5>Var6,(-1)*Var5,(-1)*Var4,6,1), , COLORRED;
STICKLINE(Var5>=REF(Var4,1),(-1)*Var5,(-1)*Var4,6,1), ,COLORGREEN;
Var7:=REF(LOW,1)*0.9;
Var8:=LOW*0.9;
Var9:=(Var8*VOL+Var7*(CAPITAL-VOL))/CAPITAL;
VarA:=EMA(Var9,30);
VarB:=CLOSE-REF(CLOSE,1);
VarC:=MAX(VarB,0);
VarD:=ABS(VarB);
VarE:=SMA(VarC,7,1)/SMA(VarD,7,1)*100;
VarF:=SMA(VarC,13,1)/SMA(VarD,13,1)*100;
Var10:=BARSCOUNT(CLOSE);
Var11:=SMA(MAX(VarB,0),6,1)/SMA(ABS(VarB),6,1)*100;
Var12:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var13:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var14:=SMA((SMA(Var13,4,1)-50)*2,3,1);
Var15:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var16:=SMA(Var15,4,1)*Var1;
Var17:=SMA(Var16,3,1);
Var18:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var19:=Var11<=25 AND Var12<-95 AND Var18>20 AND Var14<-30 AND Var17<30 AND VarA-CLOSE>=-0.25 AND VarE<22 AND VarF<28 AND Var10>50;
Var1A:=(HIGH+LOW+CLOSE)/3;
Var1B:=(Var1A-MA(Var1A,14))/(0.015*AVEDEV(Var1A,14));
Var1C:=(Var1A-MA(Var1A,70))/(0.015*AVEDEV(Var1A,70));
Var1D:=IF(Var1B>=150 AND Var1B<200 AND Var1C>=150 AND Var1C<200,10,0);
Var1E:=IF(Var1B<=-150 AND Var1B>-200 AND Var1C<=-150 AND Var1C>-200,-10,Var1D);
Var1F:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Var20:=REVERSE(Var1F);
Var21:=SMA(Var1F,3,1);
Var22:=SMA(Var21,3,1)*Var1;
Var23:=SMA(Var22,3,1)*Var1;
Var24:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
Var25:=SMA(Var24,M1,1);
散户: SMA(Var25,M1,1)*Var1, , COLORMAGENTA;
Var26:=(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M))*100;
Var27:=SMA(Var26,M1,1);
Var28:=SMA(Var27,M1,1);
主力: SMA(散户,M1,1)*Var1, , COLORYELLOW;
Var29:=COST(10);
Var2A:=(CLOSE-Var29)/Var29*100;
Var2B:=COUNT(Var2A<-2.05,3)*Var1;
主力吸货: IF(Var2B>=3,10,0), , COLORCYAN;
星星之火: IF(CROSS(5,主力吸货),20,0), , COLORRED;
Var2C:=IF(CROSS(Var19,0.5),60,0)*Var1;
大富翁: IF(CROSS(SMA(Var28,M1,1),85),75,0)*Var1, , COLORWHITE;
//{www.gUPaNg.com 股旁网_同花顺股票指标公式}
Var2D:=CROSS(SMA(MAX(CLOSE-(CLOSE+REF(CLOSE,1))/2,0),5,1)/SMA(ABS(CLOSE-(CLOSE+REF(CLOSE,1))/2),5,1)*100,(CLOSE+REF(CLOSE,1))/2) AND (CLOSE-REF(CLOSE,36))/REF(CLOSE,36)*100<-10 AND HHV(HIGH,40)*0.8>LLV(LOW,5) AND SMA((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)>80;
Var2E:=(CLOSE-OPEN)/OPEN*100;
Var2F:=REF(CLOSE,1)*Var1;
Var30:=SMA(MAX(CLOSE-Var2F,0),6,1)/SMA(ABS(CLOSE-Var2F),6,1)*100;
Var31:=COUNT(Var30<20,20)>=1*Var1;
Var32:=IF(Var2E>9 AND Var31,60,0)*Var1;
有钱人: Var2C OR Var32 OR Var2D*60, ,COLORGREEN;
Var33:=IF("RSI.RSI1">78 AND "ROC.ROC"< REF("ROC.ROC",1) OR "BIAS.BIAS3">20,80,100);
Var34:=IF(CROSS(Var23,Var22) AND Var23>75,80,100)*Var1;
DRAWTEXT(CROSS(Var19,0.5) AND COUNT(Var19=1,10)=1,35,'★')*Var1, , COLORRED;
天: IF(Var33<100 OR Var34<100,80,100), , COLORRED;

同花顺S散户原版指标公式

 

相关文章