在线检测未来函数

飞狐天龙八布指标公式

来源:Internet,编辑:股旁网,2012-02-23

MA13:=MA(CLOSE,13);
MA21:=MA(CLOSE,21);
MA34:=MA(CLOSE,34);
MA55:=MA(CLOSE,55);
MA89:=MA(CLOSE,89);
Var1:=IF(DATE<1991231,1,0);
Var2:=REF(CLOSE,1);
Var3:=SMA(MAX(CLOSE-Var2,0),6,1)/SMA(ABS(CLOSE-Var2),6,1)*100;
qVar2:=LLV(LOW,10);
qVar3:=HHV(HIGH,25);
{阶段卖出线: 3.2;3.5;卖出线: 3.5;}
动力线: EMA((CLOSE-qVar2)/(qVar3-qVar2)*4,4)/3, COLOR00ff00;
CJJR:=AMOUNT/VOL/100; {小顶}
PJJ:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
HJJR:=SUM(AMOUNT,13)/CJJR/100;
CYCN:= DMA(PJJ,VOL/HJJR);
cys:=((CLOSE-CYCN)/CYCN)*100;
{ cya1:=if(hhv(cys,8)<12 and llv(cys,8)>4,1,0);
cya2:=if(hhv(cys,7)<12 and llv(cys,7)>4,1,0);
cya3:=if(hhv(cys,6)<12 and llv(cys,6)>4,1,0);
cya4:=if(hhv(cys,5)<12 and llv(cys,5)>4,1,0);
cya5:=if(hhv(cys,4)<12 and llv(cys,4)>4,1,0); }
cya6:=if(hhv(cys,3)<12 and llv(cys,3)>4,1,0);
{ cya7:=if(hhv(cys,2)<12 and llv(cys,2)>4,1,0);
cya8:=if(cys<12 and cys>4,1,0); }
{ cya9:=if(cya1 or cya2 or cya3 or cya4 or cya5 or cya6 or cya7 or cya8,1,0); }
{www.gupang.com 股旁网_飞狐股票指标公式}
Var4:=EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16);
Var5:=1/WINNER(CLOSE);
Var6:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var7:=100-ABS(Var6);
Var8:=(CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100;Var9:=SMA(Var8,20,1);
VarA:=SMA(Var9,15,1);
VarB:=100-3*Var9+2*VarA;
VarC:=((EMA(IF(VarB>REF(VarB,1),VarB,VarB-3),3)-50)*(-1)*2/2+50)/10;
VarD:=EMA(AMOUNT,13)/EMA(VOL,13);
VarE:=(VarD/REF(VarD,1)-1)*100;
VarF:=VOL/CAPITAL*100;
Var10:=(HIGH-LOW)/((HIGH+LOW)/2)*100;
Var11:=(VarC+VarF)*Var10*VarE;
多空指数:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4, COLORRED, LINETHICK3;{BBI}
减三分一:=IF(Var11>50 AND C>MA34 AND Var11<100,50,0), STICK;
减二分一:=IF(Var11>100 AND C>MA55 AND Var11<200,100,0), STICK;
减三分二:=IF(Var11>200 AND C>多空指数,160,0), STICK;
退出:=IF(Var4>1.1 AND Var4<1.15 AND Var4<REF(Var4,1),200,0), , COLORf0f000;
止盈:=IF(Var4>1.15 AND Var4<REF(Var4,1),200,0), ,COLORRED;
支撑:=COST(10);
压支撑:=支撑*0.12,coloryellow;
tj:=ma(支撑,10);
九成:=cost(100);
di:=c<tj;
{调低d:=di*0.46 COLORYELLOW;}
调低: STICKLINE(di,0,0.26,4,0), colorf0f000;
tj2:=MA(九成,5);
tj3:=ema(winner(c),5);
动顶a:stickline(动力线>3.5/3,动力线,3.5/3,10,0), COLORRED;
底:stickline(tj3<0.2,tj3,0.2,10,0), COLORRED ;
{整期:(STICKLINE(di,0,1,1,0)*0.2), COLORGRAY ;}
DRAWTEXT(cross(tj3,0.12) and count(tj3>=0.12,10)=1,0.12,'确认底'),COLORyellow ;
顶:stickline(tj3>0.8,tj3,0.8,10,0), COLORCCFF00 ;
DRAWTEXT(cross(tj3,0.8) and count(tj3>=0.8,10)=1,0.81,'顶'),COLOR00ff00 ,LINETHICK2;
DRAWTEXT(cross(0.89,tj3) and count(tj3<=0.89,10)=1,0.853,'警'),colorf00ff0 ;
顶卖:(cross(tj3,0.8) and count(tj3>=0.8,10)), STICK,colorffffff;
drawicon(cross(tj3,0.8) and count(tj3>=0.8,10),0.6,2);
dd:=c>tj2 ;
顶d:=dd*0.76;
卖线:stickline(dd,0,0.1,5,0),colorblue;
(ema(winner(c),5)), linethick2;
VarA1:=CLOSE;
VarA2:=REF(CLOSE,1);
VarA3:=REF(CLOSE,2);
VarA4:=REF(CLOSE,3);
VarA5:=VarA1>VarA2 AND VarA1>VarA3 AND VarA1>VarA4
AND VarA1>MA(CLOSE,3) AND WINNER(CLOSE)<5/100;
VarA6:=VarA1<MA(CLOSE,3) AND WINNER(CLOSE)>95/100;
VarA7:=MIN(HHV(CLOSE,20),LLV(CLOSE,20));
买入:if(VarA5*(VarA1-VarA7*0.95)*SGN(CAPITAL<>0),0.4,0), STICK,linethick3,colorred;
drawicon(VarA5*(VarA1-VarA7*0.95)*SGN(CAPITAL<>0),0.5,1);
DRAWTEXT(cross(买入,0.1) and count(买入>0,1)=1,0.28,'买'),coloryellow;
高:=九成;
动顶:stickline(动力线>2.8/3,3.2/3,3/3.0,10,0), COLORCCFF00;
动顶卖:DRAWTEXT(cya6=1 and 动力线>2.8/3 and COUNT(cya6,5)=1,3.2/3,'动顶卖'), COLORCCFF00;
卖出:if(VarA6*(VarA1-VarA7*0.95)*SGN(CAPITAL<>0)*-0.2,0.4,0), STICK,coloryellow ;
drawicon(VarA6*(VarA1-VarA7*0.95)*SGN(CAPITAL<>0)*-0.2,0.4,2);
WW:=DRAWTEXT(cross(-0.1,卖出) and count(卖出<-0,1)=1,0.6,'卖'),COLORf0f000;
MA3b:=MA(CLOSE,3);
MA4b:=MA(CLOSE,4);
{短卖:if(CROSS(MA(CLOSE,4),
MA(CLOSE,3)) and MA3b<MA4b,0.47,0), stick,colorwhite;}
MAV1:=(2*C+H+L)/4; {NSK牛熊星}
A1:=(EMA(MAV1,3)+EMA(MAV1,6)+EMA(MAV1,12)+EMA(MAV1,24))/4;
VARA8:=WINNER( C)*100;
熊市克星线:=0.5,colorred,Linethick0;
牛市克星线:=-0.5,colorgreen,Linethick0;
VAR18:=(A1-c)/((A1+c)/2)*100;
VAR28:=(H-A1)/((A1+H)/2)*100;
DRAWTEXT(减三分一=50 AND REF(Var3,1)<92 AND COUNT(减三分一,5)=1,0.21,'减三分一'),coloryellow;
AA:=DRAWTEXT(减三分二=160 AND REF(Var3,1)<92,0.46,'减三分二');
DRAWTEXT(减二分一=100 AND REF(Var3,1)<92,0.56,'减二分一') ,color00ff00;
BB:DRAWTEXT(退出=200 AND REF(Var3,1)<92 AND COUNT(退出,5)=1,0.71,'退出'),colorf0f000;
EE:DRAWTEXT(止盈=200 AND COUNT(止盈,5)=1,0.36,'专用止盈'), COLORf00ff0;
反转:IF(VAR18>10.8 AND VARA8<35,0.8,IF(VAR28>10.5 AND VARA8<96,0,0.5)), COLORf00ff0;

飞狐天龙八布指标公式

 

相关文章