在线检测未来函数

大智慧峰谷买卖指标公式

来源:Internet,编辑:股旁网,2012-02-28

AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
Var1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=SMA(Var3,3,1);
波: Var3,colorwhite;
段: Var4,COLORYELLOW;
Var6:=CROSS(Var3,Var4) AND Var3<20;
DRAWTEXT(FILTER(Var6,10)=1,40,'买'),LINETHICK1,color00aaff,ALIGN2;
STICKLINE(FILTER(Var6,10)=1,0,90,10,0),COLORred;
Var7:=CROSS(Var4,Var3) AND Var3>80;
STICKLINE(FILTER(Var7,5)=1,0,90,10,0),COLORGREEN ;
DRAWTEXT(FILTER(Var7,5)=1,70,'卖'),LINETHICK1,COLORffcc66,ALIGN2;
趋势:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,colorwhite;
Var8:=CROSS(Var2,Var3) AND Var3>80 AND Var3>Var4;
Var9:=CROSS(趋势,Var2) AND 趋势<20 AND 趋势<段;
分批卖出:STICKLINE(Var8,50,90,10,0),COLOR008360,LINETHICK3;
分批买入:STICKLINE(Var9,40,0,10,0),Color000080,LINETHICK3;
90,COLORGREEN ;
0,COLORYELLOW ;
VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
VAR05:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
资金入场:VAR02,COLORred;
Bar1:=REF(LOW,1);
Bar2:=SMA(ABS(LOW-Bar1),13,1)/SMA(MAX(LOW-Bar1,0),13,1)*4;
Bar3:=EMA(Bar2,13);
Bar4:=LLV(LOW,34);
Bar5:=EMA(IF(LOW<=Bar4,Bar3,0),3);
Bar6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Bar7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Bar8:=Bar6<REF(Bar7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
散户:STICKLINE(Bar5>REF(Bar5,1),0,Bar5,5,0),COLORGREEN,LINETHICK1;
STICKLINE(Bar8 AND COUNT(Bar8,30)=1,0,18,5,0),COLORBLUE,LINETHICK3;
STICKLINE(Bar8 AND COUNT(Bar8,30)=1,18,36,5,0),colorff7700,LINETHICK3;
STICKLINE(Bar8 AND COUNT(Bar8,30)=1,36,60,10,0),COLORYELLOW;
DRAWTEXT(Bar8 AND COUNT(Bar8,30)=1,90,'主力进场★'),COLORYELLOW,ALIGN2;
rE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
r12:=(HIGH+LOW+CLOSE)/3;
r13:=(r12-MA(r12,14))/(0.015*AVEDEV(r12,14));
r14:=(r12-MA(r12,70))/(0.015*AVEDEV(r12,70));
r15:=IF(r13>=150 AND r13<200 AND r14>=150 AND r14<200,10,0);
r16:=IF(r13<=-150 AND r13>-200 AND r14<=-150 AND r14>-200,-10,r15);
r17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
r18:=100-ABS(r17);
r19:=IF(r18<90,r18,100);
r1A:=IF(rE>0,rE,0);
r1B:=IF(r14>=200 AND r13>=150,15,IF(r14<=-200 AND r13<=-150,-15,r16))+60;
r1C:=r1A>48 AND r1B>60 AND r19<100;
DRAWTEXT(r1C AND COUNT(r1C,25)=1,80,'分批出货'),linethick1,COLORffcc66,ALIGN2;
STICKLINE(r1C AND COUNT(r1C,25)=1,90,60,5,0),colorffcc66;
{www.gupang.com 股旁网_大智慧股票指标公式}
{aa:=WINNER(CLOSE+CLOSE*15/100)*100;
bb:=WINNER(CLOSE+CLOSE*0/100)*100;
cc:=aa-bb;
dd:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
ee:=cc<3 and dd<0.5 and OPEN<>LOW;
a1:=DYNAINFO(6);
a2:=IF(LOW>a1,0,IF(HIGH<a1,1,(a1-LOW+0.01)/(HIGH-LOW+0.01)));
a3:=VOL/WINNER(LOW);
a4:=REF(HHV(CLOSE,120),1);
a5:=REF(LLV(CLOSE,120),1);
a6:=100*(CLOSE-a5)/(a4-a5);
a7:=a2>0 or a2=1;
a8:=a7 and a3/REF(a3,3)>=3 and a6<80;
a9:=REF(a8,1) or REF(a8,2) or REF(a8,3) or REF(a8,4);
a10:=a8 and a9;
a11:=IF(FILTER(a8,3),5,0);
a12:=IF(FILTER(a10,3) or ee,10,0);
STICKLINE(a11,0,18,5,0),COLORBLUE,LINETHICK3;
STICKLINE(a12,0,18,5,0),COLORBLUE,LINETHICK3;
STICKLINE(a12,18,36,5,0),colorff7700,LINETHICK3;
小量进场:IF(a11,8,0),LINETHICK0,COLORBLUE;
大量加仓:IF(a12,88,0),LINETHICK0,colorff7700;
DRAWTEXT(a11,50,'少量进场'),COLORBLUE,ALIGN2;
DRAWTEXT(a12,70,'大量加仓'),colorff7700,ALIGN2;}

大智慧峰谷买卖指标公式

 

相关文章