在线检测未来函数

通达信线性顶底指标公式

来源:Internet,编辑:股旁网,2012-03-05

A:=(5*C+H+L+O)/8;
H1:=REF(HIGH,2);
L1:=REF(LOW,2);
D1:=HIGH>H1 AND LOW>=L1 AND A>REF(A,1);
D11:=HIGH>H1 AND LOW>=L1 AND A<=REF(A,1);
D2:=LOW<L1 AND HIGH<H1;
D3:=HIGH>H1 AND LOW<L1 AND A>REF(A,1);
D31:=HIGH>H1 AND LOW<L1 AND A<=REF(A,1);
D4:=HIGH<=H1 AND LOW>=L1;
{www.gupang.com 股旁网_通达信股票指标公式}
思路:SUM(IF(D1,HIGH,IF(D11,LOW,IF(D2,-HIGH,IF(D3,HIGH,IF(D31,-HIGH,IF(D4,0,0)))))),0)/100,COLORGREEN,LINETHICK2;
IF(思路>REF(思路,1),思路,DRAWNULL),COLORRED,LINETHICK3;
IF(思路<REF(思路,1),思路,DRAWNULL),COLORGREEN,LINETHICK2;
线2:SMA(思路,2,1),COLOR0FFFFF;
线3:SMA(线2,2,1),COLORFF00FF;
上延:HHV(MA(思路,2),15),COLORFF2626;
下延:LLV(MA(思路,2),15),COLORFF2626;
中轴:=(上延+下延)/2,COLORF900F9;
 

通达信线性顶底指标公式

 

相关文章