在线检测未来函数

通达信随心MACD指标公式

来源:Internet,编辑:股旁网,2012-03-07

UPD:COUNT(C>=O OR C>=REF(C,1),8) NODRAW;
CM60:BARSLAST(LONGCROSS(C,MA(C,60),8))+1 NODRAW COLORRED;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,24);
DEA:=EMA(DIFF,9);
ADIF:ATAN((DIFF/REF(DIFF,1)-1)*100)*180/3.1416 NODRAW;
RADIF:REF(ADIF,1) NODRAW;
C2:=IF(V>MA(V,150)*0.98,0.1,-0.1);
C1:=IF(V<MA(V,150)*0.98,-0.1,0.1);
B2:=EMA(CLOSE,55)-MA(CLOSE,60) DOTLINE COLORGREEN;
B3:=EMA(B2,9) DOTLINE COLORCYAN;
DRAWBAND(B2,RGB(120,50,50),B3,RGB(50,120,50));
MACD:=2*(DIFF-DEA), STICK,LINETHICK1 COLORCYAN;
N:=20;
MID:=MA(C,20);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:=REF(MID,1),COLORGREEN;
UB:=REF(UPPER,1),COLOR00FFFF;
LB:=REF(LOWER,1),COLOR00FFFF NODRAW;
BLTJ:=REF(L,1)<REF(LB,1) AND L>LB;
BLLDT:BARSLAST(BLTJ ) NODRAW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)) COLORRED NODRAW;
背离:REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA) NODRAW;
STICKLINE(底背离,0,0.03,1.2,1),COLOR00FF00;
{底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2 CROSSDOT;}
DRAWTEXT(底背离,0.1,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1)) ;
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF) CROSSDOT COLORRED NODRAW;
{顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK2 CROSSDOT;}
底背D:BARSLAST(底背离)+1 NODRAW COLORRED;
顶背D:A2+1 COLORGREEN NODRAW;
{判断天地量}
AA:=SUMBARS(VOL,CAPITAL);
地量:=VOL<MA(VOL,AA)*21/100 AND VOL>0;
天量:=VOL>MA(VOL,AA)*34/10 ;
MACDA:2*(DIFF-DEA), STICK,LINETHICK1 COLORCYAN;
NOTEXT3:IF(地量 AND PERIOD>4,MACD*1.5,DRAWNULL) STICK LINETHICK6 COLORYELLOW;
NOTEXT4:IF(天量 AND PERIOD>4,MACD*1.5,DRAWNULL) STICK LINETHICK6 COLORAAAAFF;
NOTEXT5:IF(V<=MA(V,5)*0.22,MACD,DRAWNULL) STICK LINETHICK4 COLORBLUE;
NOTEXT:IF(REF(MACD,1)<=MACD,MACD,DRAWNULL) STICK COLORRED;
NOTEXT1:0 LINETHICK3 COLORGRAY;
NOTEXT8:IF(V>MA(V,150)*0.98,0,DRAWNULL) COLORRED LINETHICK2 CIRCLEDOT ;
DEAA:DEA COLORYELLOW;
DIFA:DIFF COLORWHITE ;
DIFF1:EMA(CLOSE,12)-EMA(CLOSE,26) DOTLINE COLORGREEN NODRAW;
DEA1:EMA(DIFF1,9) DOTLINE COLORCYAN NODRAW;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2 CROSSDOT;
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK2 CROSSDOT;
强:IF(DIFF>MA(DIFF,2),DIFF,DRAWNULL),COLORRED LINETHICK2;
弱:IF(DEA>MA(DEA,2),DEA,DRAWNULL),COLORMAGENTA LINETHICK2;
必买: DRAWICON(REF(TROUGHBARS(3,15,1),1)=0 AND HIGH>LOW,0,25),COLORRED ,LINETHICK4;
必卖: DRAWICON(REF(PEAKBARS(3,15,1),1)=1,0,27),COLORRED,LINETHICK8;
B1:A1 NODRAW;
TOP:A2 NODRAW;
BSR:((BIDORDERVOL-BIDCANCELVOL)/(OFFERORDERVOL-OFFERCANCELVOL)-1)*10 NODRAW;
NOTEXTBRS:IF(BSR>0,DEA,DRAWNULL) COLORFFFFFF LINETHICK2 CIRCLEDOT;
HSJ:=BARSLAST(CROSS(DIFF,0) AND DIFF>=0 )+1 NODRAW;
LSJ:=BARSLAST(CROSS(0,DIFF) AND DIFF<0 )+1 NODRAW;
T:IF(DIFF>0,HSJ,LSJ) NODRAW;
IF(T=1,ABS(MACD),0) STICK LINETHICK2 COLORMAGENTA;
IF(CROSS(DEA,0),ABS(MACD),0) STICK LINETHICK2 COLORYELLOW;
S:IF(HSJ>1,SUM(ABS(MACD),T),DRAWNULL) NODRAW ;
DRAWNUMBER(ISLASTBAR ,ABS(MACD*1.02),S) COLORYELLOW;
DRAWNUMBER(T=1 ,ABS(MACD*1.02),REF(S,1)) ;
T2:REF(T,T)+T NODRAW;
Q1S:REF(S,T) NODRAW;
Q2S:=REF(S,T2) NODRAW;
BL:=Q1S/Q2S NODRAW;
{E2T:BARSLAST(CROSS(DIF,DEA) AND FILTER(CROSS(DIF,DEA) ,5) )+1 NODRAW;
E6T:BARSLAST(CROSS(DEA,DIF) AND FILTER(CROSS(DEA,DIF) ,5) )+1 NODRAW;
ET:IF(DIF>=DEA,E2T,E6T) NODRAW;
ES:SUM(ABS(DIF-DEA),ET) NODRAW;
BZ:=MAX(ABS(DEA),ABS(DIF));
XS:=IF(DIF<0,-1,1);
IF(ET=1,DIF,DRAWNULL) CIRCLEDOT LINETHICK2;
DRAWNUMBER(ISLASTBAR ,DIF*1.05,ES) COLORYELLOW;
DRAWNUMBER(ET=1 ,BZ*XS*1.05,REF(ES,1)) COLORYELLOW;};
{www.gupang.com 股旁网_通达信股票指标公式}
TTJ:=IF(BARSLAST(顶背离=1)+1=144 OR BARSLAST(顶背离=1)+1=89 OR BARSLAST(顶背离=1)+1=13 OR BARSLAST(顶背离=1)+1=47 OR BARSLAST(顶背离=1)+1=1 OR BARSLAST(顶背离=1)+1=8 OR BARSLAST(顶背离=1)+1=21 OR BARSLAST(顶背离=1)+1=34 OR BARSLAST(顶背离=1)+1=55,1,O) ;
TTJA:=IF( BARSLAST(底背离=1)+1=144 OR BARSLAST(底背离=1)+1=89 OR BARSLAST(底背离=1)+1=8 OR BARSLAST(底背离=1)+1=1 OR BARSLAST(底背离=1)+1=47 OR BARSLAST(底背离=1)+1=13 OR BARSLAST(底背离=1)+1=21 OR BARSLAST(底背离=1)+1=34 OR BARSLAST(底背离=1)+1=55,1,O) ;
DRAWNUMBER((BARSLAST(顶背离=1)+1<144 AND TTJ=1 AND CURRBARSCOUNT<233) OR ISLASTBAR,MIN(DIFF,DEA)*0.98,BARSLAST(顶背离=1)+1) COLORGREEN;
DRAWNUMBER((BARSLAST(底背离=1)+1<144 AND TTJA=1 AND CURRBARSCOUNT<233)OR ISLASTBAR,0,BARSLAST(底背离=1)+1) COLORYELLOW;

通达信随心MACD指标公式

 

相关文章