在线检测未来函数

大智慧黄金分割线+江恩八分线主图指标公式

来源:Internet,编辑:股旁网,2012-03-08

input:K(1,1,3);
DRAWGBKLAST(C>0,STRIP(RGB(90,90,90),RGB(0,0,0),0));
DRAWTEXTREL(0,3,'代码:'+STKLABEL),ColorFFFFFF;
T := BARSLAST(DISPSTATUS=1)+1;
A := DISPSTATUS=2;
HH := HHV(H, T);
LL := LLV(L, T);
HL := HH-LL;
wH := HHVBARS(H, T);
wL := LLVBARS(L, T);
KK := wH-wL;
mHL := HH-HL*0.5;
if K=1 then begin
HL191 := (HH-LL)*0.191;
HL382 := (HH-LL)*0.382;
HL618 := (HH-LL)*0.618;
HL809 := (HH-LL)*0.809;
if KK<0 then begin
a1 := HH-HL191;
a2 := HH-HL382;
a3 := HH-HL618;
a4 := HH-HL809;
end else begin
a1 := LL+HL191;
a2 := LL+HL382;
a3 := LL+HL618;
a4 := LL+HL809;
end
end
if k=1 then begin
HL125 := (HH-LL)*0.125;
HL250 := (HH-LL)*0.25;
HL375 := (HH-LL)*0.375;
HL625 := (HH-LL)*0.625;
HL750 := (HH-LL)*0.75;
HL875 := (HH-LL)*0.875;
if kk<0 then begin
b1 := HH-HL125;
b2 := HH-HL250;
b3 := HH-HL375;
b4 := HH-HL625;
b5 := HH-HL750;
b6 := HH-HL875;
end else begin
b1 := LL+HL125;
b2 := LL+HL250;
b3 := LL+HL375;
b4 := LL+HL625;
b5 := LL+HL750;
b6 := LL+HL875;
end
end
DRAWTEXT(A and K<>3,HH, ' 最高价:'+HH),ALIGN2,colorgreen;
DRAWTEXT(A and K<>3,LL, ' 最低价:'+ll),ALIGN2,VALIGN2,colorgreen;
DRAWTEXT(A and K<>3,mHL,' 50%:'+mHL),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a1, ' 0.191:'+NUMTOSTRN(a1,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a2, ' 0.382:'+NUMTOSTRN(a2,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a3, ' 0.618:'+NUMTOSTRN(a3,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a4, ' 0.809:'+NUMTOSTRN(a4,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, b1, ' 1/8:'+NUMTOSTRN(b1,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b2, ' 1/4:'+NUMTOSTRN(b2,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b3, ' 3/8:'+NUMTOSTRN(b3,2)),ALIGN0,colorgreen;
DRAWTEXT(A and K=1, b4, ' 5/8:'+NUMTOSTRN(b4,2)),ALIGN0,colorgreen;
DRAWTEXT(A and K=1, b5, ' 3/4:'+NUMTOSTRN(b5,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b6, ' 7/8:'+NUMTOSTRN(b6,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K<>3,HH, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,LL, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,mHL,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorff0000,linethick7;
DRAWTEXT(A and K=1, a1, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a2, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a3, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a4, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, b1, ' ﹉﹉﹉﹉'),ALIGN2,color00FF00;
DRAWTEXT(A and K=1, b2, ' ﹉﹉﹉﹉'),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b3, '﹉﹉'),ALIGN0,color00ff00;
DRAWTEXT(A and K=1, b4, '﹉﹉'),ALIGN0,color00ff00;
DRAWTEXT(A and K=1, b5, ' ﹉﹉﹉﹉'),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b6, ' ﹉﹉﹉﹉'),ALIGN2,color00FF00;
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
压力Ⅰ:= 2*重心-LOW;
压力Ⅱ:= 重心 + PT;
支撑Ⅰ:= 2*重心-HIGH;
支撑Ⅱ:= 重心 - PT;
DRAWTEXTABS(75,8,' 《逆势操作》'),ColorFFFF00;
DRAWTEXTABS(150,8,' 重心:'+重心),Color208FFF;
DRAWTEXTABS(75,27,' 支 撑'),ColorFFFFFF;
DRAWTEXTABS(75,44,' '+支撑Ⅰ),ColorFFFFFF;
DRAWTEXTABS(75,62,' '+支撑Ⅱ),ColorFFFFFF;
DRAWTEXTABS(75,27,' 压 力'),Color00FF00;
DRAWTEXTABS(75,44,' '+压力Ⅰ),Color00FF00;
DRAWTEXTABS(75,62,' '+压力Ⅱ),Color00FF00;
DRAWTEXTABS(75,5,'│'),Color00FFFF;
DRAWTEXTABS(75,17,'│'),Color00FFFF;
DRAWTEXTABS(75,29,'│'),Color00FFFF;
DRAWTEXTABS(75,41,'│'),Color00FFFF;
DRAWTEXTABS(75,53,'│'),Color00FFFF;
DRAWTEXTABS(75,65,'│'),Color00FFFF;
DRAWTEXTABS(218,5,'│'),Color00FFFF;
DRAWTEXTABS(218,17,'│'),Color00FFFF;
DRAWTEXTABS(218,29,'│'),Color00FFFF;
DRAWTEXTABS(218,41,'│'),Color00FFFF;
DRAWTEXTABS(218,53,'│'),Color00FFFF;
DRAWTEXTABS(218,65,'│'),Color00FFFF;
DRAWTEXTABS(146,25,'│'),Color00FFFF;
DRAWTEXTABS(146,29,'│'),Color00FFFF;
DRAWTEXTABS(146,41,'│'),Color00FFFF;
DRAWTEXTABS(146,53,'│'),Color00FFFF;
DRAWTEXTABS(146,65,'│'),Color00FFFF;
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXTABS(80,0,'────────────'),Color00FFFF;
DRAWTEXTABS(80,20,'────────────'),Color00FFFF;
DRAWTEXTABS(80,37,'────────────'),Color00FFFF;
DRAWTEXTABS(80,54,'────────────'),Color00FFFF;
DRAWTEXTABS(80,71,'────────────'),Color00FFFF;
WX:=MA(CLOSE,0);
STICKLINE(C>=O,C,O,8,0),COLOR0000AA;
STICKLINE(C>=O,C,O,6,0),COLOR0000bb ;
STICKLINE(C>=O,C,O,4,0),COLOR0000cc ;
STICKLINE(C>=O,C,O,2,0),COLOR0000ee;
STICKLINE(C>=O,H,L,0,0),COLOR0000ff;
STICKLINE(C<=O,C,O,8,0),Color7B7b00;
STICKLINE(C<=O,C,O,6,0),Color909000;
STICKLINE(C<=O,C,O,4,0),ColorA8a800;
STICKLINE(C<=O,C,O,2,0),COLORcece00;
STICKLINE(C<=O,H,L,0,0),COLORffff00;
G:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
X:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
DRAWTEXT(G,L*0.997,'▲'),ALIGN1,VALIGN0,Colorff00ff;
DRAWTEXT(G,L,' ̄'),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(X,H*1.002,'▼'),ALIGN1,VALIGN2,Color00ffff;
DRAWTEXT(X,H,' ̄'),ALIGN1,VALIGN0,Color00ffff;
ED:=barslast(G);
EF:=barslast(X);
买入到卖出天数:ED,LINETHICK0,ColorFFFFFF;
卖出到买入天数:EF,LINETHICK0,ColorFFFFFF;
换手: VOL/CAPITAL*100,LINETHICK0,colorwhite;
QQ:=换手;
DRAWTEXTREL(0,910,' 买入到到当前周期:'+NUMTOSTR(ED) +'天'+' 卖出到当前周期:'+NUMTOSTR(EF) +'天'+' 换手率:'+NUMTOSTRN(QQ,2) +'%'),colorFfff00;

大智慧黄金分割线+江恩八分线主图指标公式

 

相关文章