在线检测未来函数

通达信回马智能辅助主图指标公式

来源:Internet,编辑:股旁网,2012-03-12

VAR1T:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2T:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3T:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
STICKLINE(VAR2T < MA(VAR3T,6),LOW,HIGH,0,1),COLORLIBLUE;
STICKLINE(VAR2T > MA(VAR3T,6),LOW,HIGH,0,1),COLORRED;
STICKLINE(((OPEN>CLOSE)AND(VAR2T<MA(VAR3T,6))),(CLOSE-0.03),OPEN,2.5,0),COLORLIBLUE;
STICKLINE(((OPEN<CLOSE)AND(VAR2T<MA(VAR3T,6))),CLOSE,OPEN,2.5,1),COLORLIBLUE;
STICKLINE(((OPEN>CLOSE)AND(VAR2T>MA(VAR3T,6))),OPEN,(CLOSE-0.03),2.5,0),COLORLIRED;
STICKLINE(((OPEN<CLOSE)AND(VAR2T>MA(VAR3T,6))),OPEN,CLOSE,2.5,1),COLORRED;
DRAWICON(CROSS(VAR2T,MA(VAR3T,6)),(LOW - (LOW*0.02)),7);
DRAWICON(CROSS(MA(VAR3T,6),VAR1T),(HIGH+(HIGH*0.02)),8);
PT:=REF(H,1)-REF(L,1);
CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1);
NL:=CDP*2-REF(H,1);
强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;
{www.gupang.com 股旁网_通达信股票指标公式}
阻:IF(NH>强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORBLUE;
M:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NL<M,CDP-(CDP-M)*0.618,NL)NODRAW;
底:IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORBLUE,LINETHICK2;
HHJSJDC:MA(HHJSJDB,5),COLORYELLOW,LINETHICK2;
ZT:=C/REF(C,1)>1.090;
STICKLINE(ZT,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(ZT,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(ZT,H,L,0,0),COLORRED;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
LMIN:=REF(MIN(L,REF(C,1)),BH);
CZZ:=REF(H,BH)-LMIN;
STICKLINE(C AND BH<22,(LMIN+CZZ*0.5),(LMIN+CZZ*0.5),7,0),COLORRED;
STICKLINE(C AND BH<22,(LMIN+CZZ*0.382),(LMIN+CZZ*0.382),7,0),COLORMAGENTA;
STICKLINE(C AND BH<22,LMIN,LMIN,7,0),COLORBLUE;
VARZT:=BARSLAST(C/REF(C,1)>1.097);
STICKLINE(VARZT=2,L*0.97,L*0.98,8,0),COLOR0000FF;
DRAWTEXT(VARZT=2,L*0.95,'3天'),COLORBLUE;
STICKLINE(VARZT=4,H*1.03,H*1.02,8,0),COLOR9966FF;
DRAWTEXT(VARZT=4,H*1.06,'5天'),COLORBLUE;
STICKLINE(VARZT=7,L*0.97,L*0.98,8,0),COLOR00FFFF;
DRAWTEXT(VARZT=7,L*0.95,'8天'),COLORBLUE;
STICKLINE(VARZT=12,H*1.03,H*1.02,8,0),COLORFF33FF;
DRAWTEXT(VARZT=12,H*1.06,'13天'),COLORBLUE;
AZ1:=EMA(C,14);
AZ1X:=(AZ1-REF(AZ1,1))/REF(AZ1,1)*100,NODRAW;
出击:=IF(AZ1X>=0,REF(EMA(C,14),BARSLAST(CROSS(AZ1X,0))+1),DRAWNULL)COLORRED;
休假:=IF(AZ1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,AZ1X))+1),DRAWNULL)COLORGREEN;
STICKLINE(CROSS(AZ1X,0),C,O,2,0)COLORMAGENTA;
STICKLINE(CROSS(0,AZ1X),C,O,2,0)COLORGREEN;

通达信回马智能辅助主图指标公式

 

相关文章