在线检测未来函数

同花顺剑客指标公式

来源:Internet,编辑:股旁网,2012-03-13

A1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
A2:=SMA(ABS(LOW-A1),13,1)/SMA(MAX(LOW-A1,0),10,1);
A3:=EMA(A2,10);
A4:=LLV(LOW,33);
A5:=EMA(IF(LOW<=A4,A3,0),3);
STICKLINE(A5>REF(A5,1),0,A5,3,0 ),COLOR000055;
STICKLINE(A5>REF(A5,1),0,A5,2.6,0 ),COLOR000077;
STICKLINE(A5>REF(A5,1),0,A5,2.1,0 ),COLOR000099;
STICKLINE(A5>REF(A5,1),0,A5,1.5,0 ),COLOR0000BB;
STICKLINE(A5>REF(A5,1),0,A5,0.9,0 ),COLOR0000DD;
STICKLINE(A5>REF(A5,1),0,A5,0.3,0 ),COLOR0000FF;
STICKLINE(A5<REF(A5,1),0,A5,3,0),COLOR005500;
STICKLINE(A5<REF(A5,1),0,A5,2.6,0),COLOR007700;
STICKLINE(A5<REF(A5,1),0,A5,2.1,0),COLOR009900;
STICKLINE(A5<REF(A5,1),0,A5,1.5,0),COLOR00BB00;
STICKLINE(A5<REF(A5,1),0,A5,0.9,0),COLOR00DD00;
STICKLINE(A5<REF(A5,1),0,A5,0.3,0),COLOR00FF00;
剑客进场:IF(A5>REF(A5,1),A5,0),colorred,NODRAW;
剑客洗盘:IF(A5<REF(A5,1),A5,0),colorgreen,NODRAW;
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
看客:=IF(B6>60,B6-60,0);
T1:=STICKLINE(REF(看客,1)<看客,看客,REF(看客,1),9,0),coloryellow;
T2:=STICKLINE(REF(看客,1)>看客,看客,REF(看客,1),9,0),colorcyan;
TAI1:=MA(C,1)/MA(REF(C,13),8)*100;
TAI2:=MA(FORCAST(TAI1,21),3);
TAI3:=REF(TAI1,1);
TAI4:=REF(TAI1,2);
剑1:=LLV(LOW,8);
剑2:=HHV(HIGH,13);
#流浪剑客#:EMA((CLOSE-剑1)/(剑2-剑1)*100,5),colorred,LINETHICK1;
※升跌临界※:EMA(0.667*REF(#流浪剑客#,1)+0.333*#流浪剑客#,2),colorgreen,LINETHICK1;
//{www.gUPaNg.com 股旁网_同花顺股票指标公式}
短顶:= CROSS(※升跌临界※,#流浪剑客#) ;
DRAWTEXT(短顶,73,'↓'),colorgreen;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9),COLORFFFF00;
MACD:=(DIFF-DEA)*2;
AA1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
AA2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
背离:=REF(CLOSE,AA1+1)>CLOSE AND DIFF> REF(DIFF,AA1+1) AND CROSS(DIFF,DEA);
顶背离:=REF(CLOSE,AA2+1)< CLOSE AND REF(DIFF,AA2+1)>DIFF AND CROSS(DEA,DIFF);
¥①:IF(REF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5)) /MA(C,5)>0.04 AND 看客=0 AND C> REF(C,1),1),44,0),LINETHICK3,colorcyan;
¥②:IF(REF("KDJ.J",1)<0 AND "KDJ.J">0 AND TAI1>=TAI2 AND TAI3> TAI4,34,0),LINETHICK3,COLOR0000FF;
¥③:IF(REF(#流浪剑客#,1)<=13 AND CROSS(#流浪剑客#,※升跌临界※) AND REF(MA(C,55),1)>REF(MA(C,55),2) AND (VAR19 OR REF(VAR19,1)),23,0),colorblue,LINETHICK3;
¥④:IF(底背离,57,0),LINETHICK3,colorbrown;
DRAWTEXT(底背离,73,'←MACD 底背离'),colorwhite;
DRAWTEXT(顶背离,73,'←MACD 顶背离'),colorwhite;
DRAWICON(REF(#流浪剑客#,1)<=13 AND CROSS(#流浪剑客#,※升跌临界※) AND REF(MA(C,55),1)>REF(MA(C,55),2) AND (VAR19 OR REF(VAR19,1)),25,5);

同花顺剑客指标公式

 

相关文章