在线检测未来函数

通达信变异MACD+K线主图指标公式

来源:Internet,编辑:股旁网,2012-03-20

N:=13;M:=5;M1:=21;
ZJ:=EMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),N);
HD :=H-REF(H,1);
LD :=REF(L,1)-L;
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N);
PDI:= DMP/ZJ;
MDI:= DMM/ZJ;
快线: EMA((PDI-MDI)/(MDI+PDI)*100,M)COLOR0099FF;
慢线:EMA(快线,M)COLORFFFFFF;
ADMA:=EMA(快线,M1);
OMD:(快线-2*ADMA+慢线)/2, COLORSTICK;
{DRAWBAND(快线,RGB(155,50,50),慢线,RGB(0,100,50));}
STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,0,0),COLORRED;
STICKLINE(OMD<REF(OMD,1) AND OMD>0,0,OMD,0,0),COLORMAGENTA;
STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,0,0),COLORYELLOW;
STICKLINE(OMD<REF(OMD,1) AND OMD<0,0,OMD,0,0),COLORLIGREEN;
强:IF(快线>慢线,快线,DRAWNULL),COLOR0099FF,LINETHICK1;
弱:IF(快线<慢线,快线,DRAWNULL),COLORLIBLUE,LINETHICK1;
买入:=IF(OMD>0 AND OMD-REF(OMD,1)>0,15,0)COLORYELLOW;
D1:=(EMA(C,3)-EMA(C,8))*100;
D2:=(EMA(O,3)-EMA(O,8))*100;
D3:=(EMA(H,3)-EMA(H,8))*100;
D4:=(EMA(L,3)-EMA(L,8))*100;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(D1>=D2,D3,D4,0,1 ),COLORMAGENTA;
STICKLINE(D1>=D2,D1,D2,2.1,0 ),COLORAA00AA;
STICKLINE(D1>=D2,D1,D2,1.9,0 ),COLORCC11CC;
STICKLINE(D1>=D2,D1,D2,1.6,0 ),COLORFF22FF;
STICKLINE(D1>=D2,D1,D2,1.2,0 ),COLORFF44FF;
STICKLINE(D1>=D2,D1,D2,0.7,0 ),COLORFF66FF;
STICKLINE(D1>=D2,D1,D2,0.1,0 ),COLORFF99FF;
STICKLINE(D1< D2,D3,D4,0,1 ),COLORGREEN;
STICKLINE(D1< D2,D1,D2,2.1,0 ),COLOR005500;
STICKLINE(D1< D2,D1,D2,1.9,0 ),COLOR007700;
STICKLINE(D1< D2,D1,D2,1.6,0 ),COLOR009900;
STICKLINE(D1< D2,D1,D2,1.2,0 ),COLOR00BB00;
STICKLINE(D1< D2,D1,D2,0.7,0 ),COLOR00DD00;
STICKLINE(D1< D2,D1,D2,0.1,0 ),COLOR44FF00;

通达信变异MACD+K线主图指标公式

 

相关文章