在线检测未来函数

通达信麟龙RSI多周期指标公式

来源:Internet,编辑:股旁网,2012-04-02

N1:=3;N2:=6;
ZG:=MA(HIGH,5);
ZD:=MA(LOW,5);
ZJ:=MA(CLOSE,5);
YG:=MA(HIGH,20);
YD:=MA(LOW,20);
YJ:=MA(CLOSE,20);
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLOR00FF00,LINETHICK1;
RSI2:SMA(MAX(CLOSE-LC,0),N2,2)/SMA(ABS(CLOSE-LC),N2,1)*100,COLORFFFFFF,LINETHICK1;
MID:=MA(RSI1,10);
CMSS:=1.03*SQRT(MA(POW((RSI1-MID),2),10));
UPPER:MID+CMSS,LINETHICK1,COLOR00FFFF;
LOWER:MID -CMSS,LINETHICK1,COLORFFFF00;
{www.gupang.com 股旁网_通达信股票指标公式}
周LC:=REF(ZJ,5);
周RSI1:SMA(MAX(ZJ-周LC,0),N1*5,1)/SMA(ABS(ZJ-周LC),N1*5,1)*100,LINETHICK0;
周RSI2:SMA(MAX(ZJ-周LC,0),N2*5,1)/SMA(ABS(ZJ-周LC),N2*5,1)*100,LINETHICK0;
月LC:=REF(YJ,20);
月RSI1:SMA(MAX(YJ-月LC,0),N1*20,1)/SMA(ABS(YJ-月LC),N1*20,1)*100,LINETHICK0;
月RSI2:SMA(MAX(YJ-月LC,0),N2*20,1)/SMA(ABS(YJ-月LC),N2*20,1)*100,LINETHICK0;
STICKLINE(周RSI1>=REF(周RSI1,1),周RSI1,周RSI2,8,0),COLOR0000FF;
STICKLINE(周RSI1<REF(周RSI1,1),周RSI1,周RSI2,8,0),COLOR00FF00;
STICKLINE(月RSI1>=REF(月RSI1,1),月RSI1,月RSI2,1,0),COLOR00FFFF;
STICKLINE(月RSI1<REF(月RSI1,1),月RSI1,月RSI2,1,0),COLORFFFF00;

通达信麟龙RSI多周期指标公式

 

相关文章