在线检测未来函数

大智慧MACD+KDJ指标公式

来源:Internet,编辑:股旁网,2012-04-04

INPUT:LONG(26,20,100),SHORT(12,5,40),M(9,2,60),N(9,1,100),M1(3,2,40),M2(3,2,40);
DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIFF,M);MACD:=2*(DIFF-DEA);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);D:SMA(K,M2,1);J:3*K-2*D;KX:=BARSSINCE(CLOSE);
HKMAX:=MAX(HHV(K,KX),MAX(HHV(D,KX),HHV(J,KX)));
LKMIN:=MIN(LLV(K,KX),MIN(LLV(D,KX),LLV(J,KX)));
KDBL:=(HKMAX+LKMIN)/2;KDC:=HKMAX-LKMIN;
FDBL:=(MAX(HHV(DIFF,KX),MAX(HHV(DEA,KX),HHV(MACD,KX)))+MIN(LLV(DIFF,KX),MIN(LLV(DEA,KX),LLV(MACD,KX))))/100;
FDC:=MAX(HHV(DIFF,KX),MAX(HHV(DEA,KX),HHV(MACD,KX)))-MIN(LLV(DIFF,KX),MIN(LLV(DEA,KX),LLV(MACD,KX)));
DF:(DIFF-FDBL)*(KDC/FDC)+KDBL,COLOR0099FF,LAYER2,LINETHICK2;
{www.gupang.com 股旁网_大智慧股票指标公式}
DA:(DEA-FDBL)*(KDC/FDC)+KDBL,COLORD89837,LAYER2,LINETHICK2;
MACDA:=(MACD-FDBL)*(KDC/FDC)+KDBL;SH:=(0-FDBL)*(KDC/FDC)+KDBL;
50,COLORGRAY,DOTLINE; 0,COLORRED,POINTDOT; 100,COLORGREEN,POINTDOT;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,50,(MACDA-SH)+50,3,0),COLORRED;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,50,(MACDA-SH)+50,3,0),COLOR00DDDD;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,50,(MACDA-SH)+50,3,0),COLORCYAN;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,50,(MACDA-SH)+50,3,0),COLORFF4422;

大智慧MACD+KDJ指标公式

 

相关文章