在线检测未来函数

飞狐双周期MACD指标公式

来源:Internet,编辑:股旁网,2012-04-07

DIFF:EMA(CLOSE,24) - EMA(CLOSE,52),COLORCC33CC;
DEA:EMA(DIFF,18),color66CC00;
FILLRGN(DIFF>DEA,DIFF,DEA),COLORCC33CC;
FILLRGN(DIFF<DEA,DIFF,DEA),color669900;
DIFF本:EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE,LINETHICK1;
DEA本:EMA(DIFF本,9),COLORYELLOW,LINETHICK1;
MACD:2*(DIFF本-DEA本),COLORSTICK ;
{www.gupang.com 股旁网_飞狐股票指标公式}
A2:=IF(CROSS(0,DEA本),1,0);
A12:=IF(DIFF本>0 AND CROSS(DIFF本,DEA本),1,0);
SS2:=IF(A2,SUM(A12,0),0);
SSB2:=HHV(SS2,0);
SSS2:=SUM(A12,0);
轴上第1次金叉:=IF(SSS2-SSB2=1 AND SSS2>REF(SSS2,1),1,0);
DRAWTEXT(FILTER(轴上第1次金叉>0,5),DIFF本,'轴上第1次'),COLORWHITE;
A22:=IF(CROSS(DEA本,0),1,0);
A212:=IF(DIFF本<0 AND CROSS(DIFF本,DEA本),1,0);
SS22:=IF(A22,SUM(A212,0),0);
SSB22:=HHV(SS22,0);
SSS22:=SUM(A212,0);
轴下第2次金叉:=IF(SSS22-SSB22>1 AND SSS22>REF(SSS22,1),1,0);
DRAWTEXT(FILTER(轴下第2次金叉>0,5),DEA,'轴下2次'),COLORYELLOW;
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD,'6');
倍量:=(V/REF(V,1)>=1.91 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>=1.91);
百日低量:=REF(V,1)<=REF(LLV(V,100),1);
平量:=REF(V,2)<=REF(LLV(V,100),2) AND ABS(REF(V,1)-REF(V,2))/REF(V,2)<=0.03;
XG:=倍量 AND (百日低量 OR 平量);
QJJ:=VOL/((H-L)*2-ABS(C-O));
XVL:=IF(C>O,QJJ*(H-L),IF(C<O,QJJ*(H-O+C-L),VOL/2))+IF(C>O,0-QJJ*(H-C+O-L),IF(C<O,0-QJJ*(H-L),0-VOL/2));
HSL:=XVL/23;
流量:=HSL+REF(HSL,1)+REF(HSL,2);
LLJX:=EMA(流量,3);
量:=REF(LLJX,1)<=0 AND LLJX>0 AND HSL>0 AND XG;
DRAWTEXT(FILTER(量>0,5),DIFF,'倍量'),COLORGREEN;

飞狐双周期MACD指标公式

 

相关文章