在线检测未来函数

通达信五线顺上第一阳绝杀主图+选股指标公式

来源:Internet,编辑:股旁网,2012-04-10

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA60:=MA(C,60);
MA120:=MA(C,120);
∠5:=57.3*(ATAN(100*(MA5/REF(MA5,1)-1)));
∠10:=57.3*(ATAN(100*(MA10/REF(MA10,1)-1)));
∠20:=57.3*(ATAN(100*(MA20/REF(MA20,1)-1)));
∠60:=57.3*(ATAN(100*(MA60/REF(MA60,1)-1)));
∠120:=57.3*(ATAN(100*(MA120/REF(MA120,1)-1)));
C1:=REF(C,1);
C2:=REF(C,2);
WS1:=MA5>MA10&&MA10>MA20&&MA20>MA60&&MA60>MA120;
WS2:=∠5>0&&∠10>0&&∠20>0&&∠60>0&&∠120>0;
{www.gupang.com 股旁网_通达信股票指标公式}
WXSS:=COUNT(WS1,2)=2&&COUNT(WS2,2)=2;
WSYY:=C>MA5&&C>C1&&C>O&&WXSS&&C1<MIN(REF(MA5,1),REF(MA10,1));
DRAWTEXT(WSYY,H*1.06,'五上一阳'),COLORLIGRAY;
DRAWBAND(MA60,RGB(240,180,180),MA120,RGB(180,240,180));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(WSYY,CLOSE,OPEN,2,0),COLORYELLOW;
M1:MA5;
M2:MA10;
M3:MA20;
M4:MA60;
M5:MA120;

选股公式:
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA60:=MA(C,60);
MA120:=MA(C,120);
∠5:=57.3*(ATAN(100*(MA5/REF(MA5,1)-1)));
∠10:=57.3*(ATAN(100*(MA10/REF(MA10,1)-1)));
∠20:=57.3*(ATAN(100*(MA20/REF(MA20,1)-1)));
∠60:=57.3*(ATAN(100*(MA60/REF(MA60,1)-1)));
∠120:=57.3*(ATAN(100*(MA120/REF(MA120,1)-1)));
C1:=REF(C,1);
WS1:=MA5>MA10&&MA10>MA20&&MA20>MA60&&MA60>MA120;
WS2:=∠5>0&&∠10>0&&∠20>0&&∠60>0&&∠120>0;
WXSS:=COUNT(WS1,2)=2&&COUNT(WS2,2)=2;
WSYY:C>MA5&&C>C1&&C>O&&WXSS&&C1<MIN(REF(MA5,1),REF(MA10,1));

通达信五线顺上第一阳绝杀主图+选股指标公式

 

相关文章