在线检测未来函数

通达信堪称一绝指标公式

来源:Internet,编辑:股旁网,2012-04-14

RSV:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);
神仙:MEMA(RSV,3),COLORWHITE;
魔鬼:SMA(SMA(RSV,3,1),3,1),COLORYELLOW;
轨迹:SMA(SMA(SMA(RSV,3,1),3,1),3,1),COLORMAGENTA;
DRAWBAND(神仙,RGB(150, 0, 50 ), 魔鬼,RGB( 0, 60, 60)) ;
DRAWBAND(魔鬼,RGB(100, 0, 0 ), 轨迹,RGB( 0, 50,0)) ;
LSC:=REF(C,1);
RMI:=SMA(MAX(C-LSC,0),5,1)/SMA(ABS(C-LSC),5,1)*100;
RMIM:=SMA(RMI,3,1);
STICKLINE(RMIM>=50,50,RMIM,4,0),COLOR000080;
STICKLINE(RMIM>=50,50,RMIM,3,0),COLOR0000A6;
STICKLINE(RMIM>=50,50,RMIM,2,0),COLOR0000CE;
STICKLINE(RMIM>=50,50,RMIM,1,0),COLOR0000FF;
STICKLINE(RMIM<50,50,RMIM,4,0),COLOR800000;
STICKLINE(RMIM<50,50,RMIM,3,0),COLORB00000;
STICKLINE(RMIM<50,50,RMIM,2,0),COLORD50000;
STICKLINE(RMIM<50,50,RMIM,1,0),COLORFF0000;
STICKLINE(RMIM>80,80,RMIM,5,0),COLORGREEN;
STICKLINE(RMIM<20,20,RMIM,5,0),COLORWHITE;
A:=(C*3+O+H+L)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
LX:=REF(XJ,1);
D1:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100,COLOR0000FF;
D2:=(SMA(MAX(XJ-LX,0),7,1)/SMA(ABS(XJ-LX),7,1))*100,COLOR00FFFF;
N:=10;M1:=2;M2:=2;
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);
X01:=LLV(Q_2,2)=LLV(Q_2,7) ;
X2:=COUNT(Q_2<0,2);
X3:=CROSS(Q_2,MA(Q_2,2));
X4:=REF(Q_B,1)<REF(Q_B,2);
X5:=Q_A>REF(Q_B,1);
买进:=(X01 AND X2 AND X3) AND X4 AND X5;
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
堪称一绝:STICKLINE(REF(TJ,1)=0 AND TJ>=1 AND CCI<-40 ,80,20,0,-1) ,COLORRED;
地狱底:0,POINTDOT,COLORGRAY;
地狱线:10,POINTDOT,COLORGRAY;
地平线:20,COLORLIMAGENTA;
天际线:80,COLORGRAY;
清仓线:90,POINTDOT;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWICON(CROSS(神仙,魔鬼) AND 神仙<=15,10,40);
DRAWICON((CROSS(神仙,10)),5,1);
DRAWICON((CROSS(魔鬼,RSI)) AND RSI>60,魔鬼,8);
P:神仙;R:魔鬼;G:轨迹;
关注:IF((REF(C,2)-REF(O,2))/REF(O,2)<=-0.002 AND (REF(O,1)-REF(C,2))/REF(C,2)<=0.01
AND (REF(C,1)-REF(O,1))/REF(O,1)<=-0.001 AND (O- REF(O,1))/REF(O,1)<=0
AND (C-O)/O>=0 {AND (C-O)/O<=0.02}
AND (MA(C,60)-C)/C>=0.2 AND CROSS(神仙,10),25,0);

通达信堪称一绝指标公式

 

相关文章