在线检测未来函数

通达信超前MACD捉牛股指标公式

来源:Internet,编辑:股旁网,2012-04-27

SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLOR00FFFF,LINETHICK2;
DEA:EMA(DIFF,7),COLORFF33FF,LINETHICK2;
MACD: (DIFF-DEA)*2,COLORSTICK;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,0.3,0),COLORYELLOW,POINTDOT;
STICKLINE(低位金叉,0,15,8,0),COLORYELLOW;
DRAWICON(低位金叉,0.3,1);
{www.gupang.com 股旁网_通达信股票指标公式}
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORFF00FF,POINTDOT;
STICKLINE(二次金叉,30,15,8,0),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0.1,0),COLORRED,POINTDOT;
STICKLINE(底背离,45,30,8,0),COLORRED;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),COLORGREEN;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN;
A3:=CROSS(DIFF,DEA) AND DEA<0;
零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT;
STICKLINE(零下二次金叉,45,60,8,0),COLORWHITE;

通达信超前MACD捉牛股指标公式

 

相关文章