在线检测未来函数

通达信弱市抄底指标公式

来源:Internet,编辑:股旁网,2012-05-05

X:=C-REF(MA(C,20),11);
LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;
{www.gupang.com 股旁网_通达信股票指标公式}
LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;
MA3:= MA(C,3);
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(C,13)*X;
CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),10,0);
满仓:IF((VMC>0),60,0),COLORRED;
半仓:IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,50,0);
V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;
V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));
买一点:IF((V93 OR V90),10,0);
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,1);
买二点:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,20,0);
YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
ST:=IF(CROSS(YT,YY),30,0);
VAR5PT:=(HIGH+LOW+CLOSE)/3;
VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));
VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));
SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);
VAR3QQ:=REF(CLOSE,1);
VAR4QQ:=SMA(MAX(CLOSE-VAR3QQ,0),6,1)/SMA(ABS(CLOSE-VAR3QQ),6,1)*100;
SM:=IF(CROSS(80,VAR4QQ),30,0);
卖点:IF((SM AND (SA OR ST)),30,0);

通达信弱市抄底指标公式

 

相关文章