在线检测未来函数

大智慧工作线+选股指标公式

来源:Internet,编辑:股旁网,2012-05-08

M20:MA(CLOSE,20),COLORWHITE;
M60:MA(CLOSE,60),COLORBLUE;
MA144:=MA(CLOSE,144);
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
A2:=BARSLAST(REF(CROSS(DIFF,DEA),1));
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
HONGJU:=IF(VAR1>0,VAR1,0);
GAOPAO:=CROSS(DIFF,DEA) AND HONGJU>=40;
DRAWTEXT(GAOPAO,HIGH*1.03,'顶背'),COLORGREEN;
DRAWICON(GAOPAO,HIGH*1.02,6);
LLVV:=LLV(LOW,5);
DIXI:=CROSS(DEA,DIFF) AND REF(DEA,A1+1)>0 AND DEA<0;
DRAWICON(DIXI,LOW*0.98,10);
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXT(DIXI,LOW*0.96,'波段低吸'),COLORYELLOW;
工作线:EMA(CLOSE,17),COLORYELLOW,LINETHICK3;
生命线:MA(CLOSE,56),COLORRED;
M0:=MA(CLOSE,5);
M10:=MA(CLOSE,12);
M1:=MA(CLOSE,20);
M30:=MA(CLOSE,30);
M2:=MA(CLOSE,60);
M3:=MA(CLOSE,240);
M4:=MA(CLOSE,120);
M41:=MA(CLOSE,41);
TJ2:=MA(CLOSE,3)<M2;
VAR2:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR2,13)-EMA(VAR2,73);
SD:=EMA(SK,2);
短线:=CROSS(SK,SD) AND SK<0.05 AND (VOL/MA(VOL,5)>2 OR CLOSE/REF(CLOSE,1)>0.035 AND CLOSE>EMA(CLOSE,17));
STICKLINE(短线,HIGH,LOW,0.5,0),COLORFFFF00;
STICKLINE(短线,OPEN,CLOSE,10,1),LINETHICK2,COLORFFFF00;
CY:=BARSLAST(短线);
MACD双底:=REF(LOW,A2+1)<CLOSE AND CROSS(DIFF,DEA);
介入:=COUNT(短线,4)=1 AND COUNT(MACD双底,1)=1 AND CLOSE/MA(CLOSE,56)*1000>980 AND CLOSE>OPEN AND VOL>=MA(VOL,5) AND DIFF>=-0.1;
DRAWTEXT(介入,LOW,'起涨点'),COLORRED;
DRAWICON(介入,LOW,7);
反向顶背:=REF(CLOSE,A2+1)>CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
逃顶:=CROSS(SD,SK) AND SK>0.2 AND VOL/MA(VOL,5)<2;
逃顶成立:=COUNT(逃顶,4)=1 AND COUNT(反向顶背,1)=1;
DRAWICON(逃顶成立,HIGH*1.01,5);
DRAWTEXT(逃顶成立,HIGH*1.03,'逃顶'),COLORGREEN;
N1G:=CLOSE/REF(CLOSE,1)>=1.097 AND HIGH=CLOSE AND NOT(OPEN=HIGH);
A1G:=BARSLAST(N1G);
A2G:=LLV(LOW,A1G-1)>REF(LOW,A1G) AND CLOSE/REF(OPEN,A1G)>1 AND CLOSE/REF(OPEN,A1G)<=1.04;
XGGG:=FILTER(A2G,10) AND A1G>=4 AND A1G<=20;
DRAWTEXT(XGGG,LOW*0.98,'涨停秘笈'),COLORYELLOW;
DRAWICON(XGGG,LOW,4);
MA20:=MA(CLOSE,20);
XPP1:=CROSS(DEA,DIFF) AND CLOSE>MA20 AND MA20>REF(MA20,1) AND DIFF>REF(DIFF,A2+1);
DRAWTEXT(XPP1,LOW*0.98,'强势洗盘'),COLORWHITE;
DRAWICON(XPP1,LOW,3);
XPP2:=XPP1 AND A1G>=4 AND A1G<=20;
DRAWICON(XPP2,LOW*0.98,12);
高1:=hhvall(h)=h;
h1:=if(高1,h,0);
hh:=if(h=h1,0,h);
高2:=hhvall(hh)=h;
DRAWLINE(高1, h,高2,h,1);
DRAWTEXTABS(0,10,'■注意:黄线上工作,黄线下休息。'),COLORYELLOW,LINETHICK2;

选股公式:
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A2:=BARSLAST(REF(CROSS(DIFF,DEA),1));
MA20:=MA(CLOSE,20);
XG:CROSS(DEA,DIFF) AND CLOSE>MA20 AND MA20>REF(MA20,1) AND DIFF>REF(DIFF,A2+1);

大智慧工作线+选股指标公式

 

相关文章