在线检测未来函数

通达信自动画通道+庄家成本+大胆做多主图指标公式

来源:Internet,编辑:股旁网,2012-05-15

N:=15;UR:=6;LR:=6;
TC1:=IF(H=HHV(H,8*UR),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,8*LR),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;{低点定位}
HP:=CURRBARSCOUNT<=TC2 AND H=UPPER;{高点定位}
STICKLINE(IF(BC2>TC2,HP,LP),LOWER,UPPER,0,0),COLOR628962;
STICKLINE(IF(BC2>TC2,LP,HP),LOWER,UPPER,0,0),COLOR628962;
NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));{用时}
LR1:=FORCAST(C,NOD+1);
NP:IF(CURRBARSCOUNT<=MAX(BC2,TC2),CONST(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-1))),DRAWNULL),POINTDOT,COLOR93BDA8;{近点}
LR2:=SLOPE(C,NOD+1);
LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)));
FP:NP-LR3*(NOD),POINTDOT,COLOR93BDA8;{远点}
EQU:(NP+FP)/2,POINTDOT,COLOR93BDA8;
AD:=ABS(NP-FP);{高差};
DBL:=BARSLAST(BC1!=DRAWNULL)+1;
DBH:=BARSLAST(TC1!=DRAWNULL)+1;
BSP:=IF(BC2>TC2,DBL,DBH)-1;
LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);
AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
AT3:=CONST(BARSLAST(AT1-LRL=AT2));
AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));
AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));
ATL:=LRL+AT5;
UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL);
UT2:=HHV(LRL-UT1,MAX(BC2,TC2));
UT3:=CONST(BARSLAST(LRL-UT1=UT2));
UT4:=CONST(IF(UT3=0,H,REF(H,UT3)));
UT5:=CONST(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)));
UTL:=LRL-UT5;
RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));{限制高}
RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));{限制低}
中轨:IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLOR628962;
上轨:IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLOR628962;
下轨:IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLOR628962;
MA1:=MA(CLOSE,5);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
TJ1:=BARSLAST(CROSS(DIF,DEA));
TJ2:=REF(H,TJ1);
IF(TJ1<30,TJ2,DRAWNULL),COLORGREEN,LINETHICK1;{30为横线延伸天数}
IF(CROSS(DIF,DEA),H*1.005,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK;
STICKLINE(CROSS(DIF,DEA),H*1.0005,H*0.9995,7,0),COLORGREEN;
{www.gupang.com 股旁网_通达信股票指标公式}
ADD:=SUMBARS(V ,CAPITAL*1);{累计换手=100%的周期}
A2:=SUM(COST(20),ADD)/ADD;{在A周期里获利20%的平均价}
A1:=SUM(COST(10),ADD)/ADD;{在A周期里获利10%的平均价}
A3D:=SUM(COST(30),ADD)/ADD;{在A周期里获利30%的平均价}
A4D:=SUM(COST(40),ADD)/ADD;{在A周期里获利40%的平均价}
A5D:=SUM(COST(50),ADD)/ADD;{在A周期里获利50%的平均价}
E:=LLV(L,250)=L;{一年中最低价的位置}
E1:=BARSLAST(E);{求得一年中最低价的位置到现在的周期}
庄家成本:(5*A1+4*A2+3*A3D+2*A4D+A5D)/15, CIRCLEDOT,COLOR00FFFF;{求的启动点的价位}
OK1:STICKLINE(CROSS(C,庄家成本) AND E1>=40 ,O ,C ,5 ,0 ),COLOR00FFFF;{得到启动点};
A线:=HHV(H,20);
B线:=LLV(L,20);
C线:=(A线+B线)/2;
做多线:IF(C线,C线,DRAWNULL)COLORFF00FF,LINETHICK2;

通达信自动画通道+庄家成本+大胆做多主图指标公式

 

相关文章