在线检测未来函数

通达信资金能量潮指标公式

来源:Internet,编辑:股旁网,2012-05-17

{仿指南针:资金趋势}
DRAWBAND(3*(EMA(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*5+20,RGB(250,80,80),20,RGB(0,180,180 ));
DRAWTEXT(ISLASTBAR,20.5,'资金趋势'),COLORMAGENTA ;
{仿指南针:主力资金}
A:=VOL*CLOSE;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,8);
主力资金:(B-B1)*100/B,NODRAW,COLORRED;
DRAWBAND(主力资金+35,RGB(250,0,00),35,RGB(0,255,0));
DRAWTEXT(ISLASTBAR,35.5,'主力资金'),COLORRED;
资金趋势:3*(EMA(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*5,NODRAW,COLORMAGENTA;
{通达信版融胜解盘用的能量潮}
VAR2:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200*10;
能量: SMA(VAR2,5,1)/100,COLORRED;
DRAWBAND(能量>REF(能量,1),RGB(250,0,120),0,RGB(0,180,180));
STICKLINE(能量>REF(能量,1),0,能量,2.5,0),COLOR7800FF;
STICKLINE(能量<REF(能量,1),0,能量,2.5,0),COLORFF7800;
危险区:18,COLOR208FFF;
次险区:15,COLORFF33FF,DOTLINE;
{www.gupang.com 股旁网_通达信股票指标公式}
VAR3:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
VAR4:=(IF(CLOSE>OPEN,VAR3*(HIGH-LOW),IF(CLOSE<OPEN,VAR3*(HIGH-OPEN+CLOSE-LOW),VOL/2))/(IF(CLOSE>OPEN,0-VAR3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-VAR3*(HIGH-LOW),0-VOL/2))*(-1))-IF(CLOSE>OPEN,0-VAR3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-VAR3*(HIGH-LOW),0-VOL/2))*(-1)/IF(CLOSE>OPEN,VAR3*(HIGH-LOW),IF(CLOSE<OPEN,VAR3*(HIGH-OPEN+CLOSE-LOW),VOL/2)));
VAR5:=AMOUNT/(100*VOL);
VAR6:=MA(VAR5,40);
VAR7:=100*(CLOSE-VAR6)/VAR6;
底部区: IF(VAR4>0 AND VAR7<-12 AND CLOSE/OPEN>1.07,300,200)/100,COLORFFFF00,DOTLINE;
DRAWTEXT(ISLASTBAR,1.5,' 能量潮'),COLOR7800FF ;
量堆:=COUNT(V>=REF(V,1)*2,BARSLAST(CROSS(C,MA(C,20))));
量堆(:IF(量堆=1,1000,0)/100,COLORYELLOW,LINETHICK3;

通达信资金能量潮指标公式

 

相关文章