在线检测未来函数

飞狐天空系列1号主图指标公式

来源:Internet,编辑:股旁网,2012-05-29

势底:=SUM(CLOSE,25)/28;
势顶:=SUM(CLOSE,25)/22,POINTDOT,LINETHICK2,colorFF00;
主线:=WMA(CLOSE,20);
主线2:WMA(CLOSE,20),LINETHICK2;
VAR1:=POW(CLOSE-主线,1);
VAR2:=MA(VAR1,3);
VAR3:=SQRT(VAR2);
阻力线:=主线+1.96*VAR3;
支撑线:=主线-1.96*VAR3;
PARTLINE(主线2>REF(主线2,1) AND 阻力线<>支撑线,主线2),LINETHICK2,colorFF;
PARTLINE(主线2<REF(主线2,1),主线2),LINETHICK2,colorFF00;
PARTLINE(主线2<REF(主线2,1),主线2),LINETHICK2,colorFF00;
PARTLINE(阻力线=支撑线,主线2),LINETHICK2,colorFF0000;
VAR11:=(2*CLOSE+OPEN+HIGH+LOW)/5;
VAR12:=VOL;
M1:=SUM(VAR11*VAR12,1)/SUM(VAR12,1);
M5:=SUM(VAR11*VAR12,5)/SUM(VAR12,5);
M13:=SUM(VAR11*VAR12,13)/SUM(VAR12,13);
M8:=SUM(VAR11*VAR12,3)/SUM(VAR12,3);
M21:=SUM(VAR11*VAR12,21)/SUM(VAR12,21);
Y:=M1;
U1:=M5;
主力:=M8;
U3:=M13;
XX1:=U1>主力 AND 主力>U3;
C5:=IF(XX1>0,LLV(U1,5),HHV(主力,5));
C8:=IF(XX1>0,LLV(主力,8),HHV(主力,5));
C13:=IF(XX1>0,LLV(U3,13),HHV(主力,5));
散户:=LLV(主力,20);
临界线:=WMA(CLOSE,5);
VAR1:=POW(CLOSE-临界线,1);
VAR2:=MA(VAR1,3);
VAR3:=SQRT(VAR2);
阻力线:=临界线+1.96*VAR3;
支撑线:=临界线-1.96*VAR3;
PARTLINE(临界线>REF(临界线,1) AND 阻力线<>支撑线,临界线),LINETHICK3,colorFF;
PARTLINE(临界线<REF(临界线,1),临界线),LINETHICK2,colorFF00;
PARTLINE(阻力线=支撑线,临界线),LINETHICK2,colorFF0000;
VAR1:=(CLOSE+HIGH+LOW)/3;
CB:=MA(VAR1,4);
A1:=HHV(CB,18);
A2:=HHV(CB,41);
A3:=HHV(HIGH,62)*0.98;
B1:=LLV(CB,18);
B2:=LLV(LOW,62)*1.02;
MID:=MA(CLOSE,20);
UPPER:=MID+2*STD(CLOSE,20);
LOWER:=MID-2*STD(CLOSE,20);
VAR1:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,27)+2*STD(CLOSE,27);
MID:=MA(CLOSE,20);
UPPER:=MID+2*STD(CLOSE,20);
LOWER:=MID-2*STD(CLOSE,20);
V1:=(CLOSE-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);
K1:=SUM(LLV(V2,4),4)/4;
V3:=EMA(V2,64)*10;
V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;
E:=V2>V4;
KS:=V5>10;
RKS:=V3<=10 OR V2<=V4 OR V5<=10;
MLS:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
开:=REF(MLS,1);
高:=开/MLS>1.23 AND 开>13 AND CLOSE/REF(CLOSE,1)>1.03;
低:=OPEN;
收:=HIGH;
VARQS49:=LOW;
VARQS50:=CLOSE;
超跌:STICKLINE(MLS>13,收,VARQS49,0,1),LINETHICK2,colorFFFFFF;
反弹:STICKLINE(高=1,收,VARQS49,0,1),LINETHICK2,colorFF00FF;
上线:=SMA(CLOSE,6.5,1);
下线:=SMA(CLOSE,13.5,1);
上线界:=SMA(CLOSE,3,1);
下线界:=SMA(CLOSE,8,1);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13);DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
A7:=(2*CLOSE+HIGH+LOW)/4;白色主力线:MA(A7,5),LINETHICK2;
操作界:=MA(A7,5)*1.03;
操作界限:=MA(A7,5)*0.97;
压力:HHV(A7,21);
支撑:LLV(A7,21);
SK:=EMA((A7-支撑)/(压力-支撑)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;input:N(3,1,100),STEP(2,1,100),MAXP(20,5,100);
SJ:=(年月日 <= 1041231);
VAR1:=(除权数据(1) + 除权数据(2));
CAP:=收盘价;
CAP[序列数据量]:=1;
FOR I=序列数据量 downto 2 DO
CAP[(I - 1)]:=(CAP[I] / (1 + (VAR1[I] / 10)));
CAPI:=((CAP * 流通盘大小) / 100);
HS:=(成交量 / CAPI);
成本:="xt1@CYCMAX";
成本1:=动态移动平均(((成交额 / 成交量) / 100),((0.8 * HS) / 100));
画区间彩带(((成本 < 成本1) AND (收盘价 < 100)),成本,成本1),colorCC6666;
画区间彩带(((成本 >= 成本1) AND (收盘价 < 100)),成本,成本1),color5022DD;
AA:=(向前引用(最高价,N) = 最高值(最高价,((2 * N) + 1)));
AAA:=信号过滤(AA,N);
BB:=向前赋值(AAA,(N + 1));
CC1:=信号过滤(BB,N);
CC:=(CC1 OR 是否最后周期);
AA2:=(向前引用(最低价,N) = 最低值(最低价,((2 * N) + 1)));
AAA2:=信号过滤(AA2,N);
BB2:=向前赋值(AAA2,(N + 1));
CC22:=信号过滤(BB2,N);
CC2:=(CC22 AND 求逻辑非(CC1));
EA:=向前赋值(CC,(向前引用(上一次条件成立位置(CC2),1) + 1));
EB:=(EA > 向前引用(EA,1));
EE:=向前赋值(EB,2);
FF1:=(EE > 向前引用(EE,1));
EE2:=向前赋值((FF1 AND (统计总数(CC,(向前引用(上一次条件成立位置(CC2),1) + 2)) = 0)),(向前引用(上一次条件成立位置(CC2),1) + 2));
FF2:=(EE2 > 向前引用(EE2,1));
EE3:=向前赋值((FF2 AND (统计总数(CC,(向前引用(上一次条件成立位置(CC2),1) + 2)) = 0)),(向前引用(上一次条件成立位置(CC2),1) + 2));
FF3:=(EE3 > 向前引用(EE3,1));
JS:=条件函数(CC,统计总数(CC2,(向前引用(上一次条件成立位置(CC),1) + 1)),0);
G1:=条件函数(((JS = 1) AND CC),上一次条件成立位置(FF1),0);
GA:=条件函数((CC AND (向前引用(最低价,上一次条件成立位置(FF1)) >= 向前引用(最低价,上一次条件成立位置(FF2)))),上一次条件成立位置(FF2),上一次条件成立位置(FF1));
G2:=条件函数(((JS = 2) AND CC),GA,0);
G3:=条件函数(((JS >= 3) AND CC),条件函数((CC AND (向前引用(最低价,GA) >= 向前引用(最低价,上一次条件成立位置(FF3)))),上一次条件成立位置(FF3),GA),0);
GG:=((G1 + G2) + G3);
JA:=向前赋值(CC,GG);
JB:=(JA > 向前引用(JA,1));
JJ:=向前赋值(JB,2);
LD:=(JJ > 向前引用(JJ,1));
LD1:=(LD OR 是否最后周期);
HEA:=向前赋值(LD1,(向前引用(上一次条件成立位置(CC),1) + 1));
HEB:=(HEA > 向前引用(HEA,1));
HEE:=向前赋值(HEB,2);
HFF1:=(HEE > 向前引用(HEE,1));
HEE2:=向前赋值((HFF1 AND (统计总数(LD1,(向前引用(上一次条件成立位置(CC),1) + 2)) = 0)),(向前引用(上一次条件成立位置(CC),1) + 2));
HFF2:=(HEE2 > 向前引用(HEE2,1));
HEE3:=向前赋值((HFF2 AND (统计总数(LD1,(向前引用(上一次条件成立位置(CC),1) + 2)) = 0)),(向前引用(上一次条件成立位置(CC),1) + 2));
HFF3:=(HEE3 > 向前引用(HEE3,1));
HJS:=条件函数(LD1,统计总数(CC1,(向前引用(上一次条件成立位置(LD1),1) + 1)),0);
HG1:=条件函数(((HJS = 1) AND LD1),上一次条件成立位置(HFF1),0);
HGA:=条件函数((LD1 AND (向前引用(最高价,上一次条件成立位置(HFF1)) <= 向前引用(最高价,上一次条件成立位置(HFF2)))),上一次条件成立位置(HFF2),上一次条件成立位置(HFF1));
HG2:=条件函数(((HJS = 2) AND LD1),HGA,0);
HG3:=条件函数(((HJS >= 3) AND LD1),条件函数((LD1 AND (向前引用(最高价,HGA) <= 向前引用(最高价,上一次条件成立位置(HFF3)))),上一次条件成立位置(HFF3),HGA),0);
HGG:=((HG1 + HG2) + HG3);
HJA:=向前赋值(LD1,HGG);
HJB:=(HJA > 向前引用(HJA,1));
HJJ:=向前赋值(HJB,2);
HD:=(HJJ > 向前引用(HJJ,1));
X1:=向前赋值(是否最后周期,(上一次条件成立位置(LD) + 1));
X2:=(X1 > 向前引用(X1,1));
Y1:=向前赋值(是否最后周期,(上一次条件成立位置(HD) + 1));
Y2:=(Y1 > 向前引用(Y1,1));
Z1:=条件函数((上一次条件成立位置(X2) < 上一次条件成立位置(Y2)),X2,Y2);
Z2:=条件函数((上一次条件成立位置(X2) < 上一次条件成立位置(Y2)),最低价,最高价);
UU:=向前赋值(是否最后周期,(上一次条件成立位置(LD) + 1));
VV:=(UU > 向前引用(UU,1));
WW:=向前赋值(VV,(向前引用(上一次条件成立位置(LD),1) + 2));
XX:=(WW > 向前引用(WW,1));
WWW:=向前赋值(XX,(向前引用(上一次条件成立位置(LD),1) + 2));
XXX:=(WWW > 向前引用(WWW,1));
WW13:=向前赋值(WW,(向前引用(上一次条件成立位置(HD),1) + 2));
WW14:=向前赋值(WW13,(向前引用(上一次条件成立位置(HD),1) + 2));
UU2:=向前赋值(是否最后周期,(上一次条件成立位置(HD) + 1));
VV2:=(UU2 > 向前引用(UU2,1));
WW2:=向前赋值(VV2,(向前引用(上一次条件成立位置(HD),1) + 2));
XX2:=(WW2 > 向前引用(WW2,1));
WW3:=向前赋值(WW2,(向前引用(上一次条件成立位置(HD),1) + 2));
XX3:=(WW3 > 向前引用(WW3,1));
WW4:=向前赋值(WW3,(向前引用(上一次条件成立位置(HD),1) + 2));
XX4:=(WW4 > 向前引用(WW4,1));
CS2:=((向前引用(最高价,上一次条件成立位置(XX2)) - 向前引用(最高价,上一次条件成立位置(XX3))) / (上一次条件成立位置(XX3) - 上一次条件成立位置(XX2)));
压力2:=(向前引用(最高价,上一次条件成立位置(XX3)) + (上一次条件成立位置(XX3) * CS2)),colorFF00;
CS3:=((向前引用(最高价,上一次条件成立位置(VV2)) - 向前引用(最高价,上一次条件成立位置(XX2))) / (上一次条件成立位置(XX2) - 上一次条件成立位置(VV2)));
压力1:=(向前引用(最高价,上一次条件成立位置(VV2)) + (上一次条件成立位置(VV2) * CS3)),LINETHICK1,colorFF00FF;
CS4:=((向前引用(最高价,上一次条件成立位置(XX3)) - 向前引用(最高价,上一次条件成立位置(XX4))) / (上一次条件成立位置(XX4) - 上一次条件成立位置(XX3)));
压力3:=(向前引用(最高价,上一次条件成立位置(XX3)) + (上一次条件成立位置(XX3) * CS4)),LINETHICK1,colorFF;
SCSM:=((向前引用(最高价,上一次条件成立位置(VV2)) - 向前引用(最低价,上一次条件成立位置(XX))) / (上一次条件成立位置(XX) - 上一次条件成立位置(VV2)));
趋势生命:=(向前引用(最低价,上一次条件成立位置(VV)) + (上一次条件成立位置(VV) * SCSM)),LINETHICK2,colorFFFFFF;
FSL:=((向前引用(最高价,上一次条件成立位置(VV2)) - 向前引用(最低价,上一次条件成立位置(VV))) / (上一次条件成立位置(VV2) - 上一次条件成立位置(VV)));
分水领1:=(向前引用(最低价,上一次条件成立位置(VV)) + (上一次条件成立位置(VV) * FSL));
分水领2:=(向前引用(最高价,上一次条件成立位置(VV2)) + (上一次条件成立位置(VV2) * FSL));
分水领:=条件函数(((上一次条件成立位置(VV2) - 上一次条件成立位置(VV)) > 0),分水领1,分水领2),LINETHICK2,colorFF0000;
显示数字((HD AND ((WW14 OR VV2) OR VV)),(最高价 * 1.02),最高价,2),ALIGN0,SHIFT1,colorFF00FF;
{www.gupang.com 股旁网_飞狐股票指标公式}
TP:=((交叉函数(收盘价,压力1) OR 交叉函数(收盘价,压力2)) OR 交叉函数(收盘价,压力3));
周K:=引用指标(品种代码,'kdj.k',0,7);
周D:=引用指标(品种代码,'kdj.d',0,7);
历史流通盘{万股}:=CAPI;
ZF:=(((最高价 - 最低价) * 100) / 最低价);
STZF:=(((收盘价 - 开盘价) * 100) / 开盘价);
SPZF:=(((收盘价 - 最低价) * 100) / 最低价);
STZFB:=(STZF / ZF);
SPZFB:=(SPZF / ZF);
最大震幅:=向前引用(最高值(ZF,5),1);
最小震幅:=向前引用(最低值(ZF,5),1);
XZFB:=(ZF / 最大震幅);
DZFB:=(ZF / 最小震幅);
XHSB:=(HS / 向前引用(最高值(HS,4),1));
DHSB:=(HS / 向前引用(最低值(HS,4),1));
DY1:=(0 - (5 * (((((STZFB >= 0.48) AND (SPZFB > 0.5)) AND (DZFB > 2)) AND (DHSB > 2)) AND (收盘价 > 开盘价))));
DY2:=(0 - (5 * ((((STZFB >= 0.8) AND (DZFB > 1.5)) AND (DHSB > 1.5)) AND (收盘价 > 开盘价))));
DY3:=(0 - (5 * ((((((STZFB >= 0.82) AND (XZFB > 0.9)) AND (DZFB > 1.5)) AND (XHSB > 0.9)) AND (DHSB > 1.5)) AND (收盘价 > 开盘价))));
单阳:=信号过滤((((DY1 OR DY2) OR DY3) AND (周K > 周D)),3);
VV1:=(单阳 * 最低价);
TS:=(((上一次条件成立位置((单阳 > 0)) + 1) >= 1) AND (上一次条件成立位置((单阳 > 0)) <= 13));
单阳高:=向前引用(最高值(最高价,上一次条件成立位置((单阳 > 0))),1);
单阳攻击:=(交叉函数(收盘价,单阳高) AND TS);
强势攻击:=条件函数(((单阳 = 1) AND (单阳攻击 = 1)),1,0);
单阳低点:=向前引用(最低价,上一次条件成立位置(VV));
单阳不破:=(TS AND (最低价 >= 单阳低点));
时间:=条件函数((最低价 >= 单阳低点),上一次条件成立位置((单阳 < 0)),0);
单阳启稳:=((交叉函数(HS,ZF) AND (收盘价 > 开盘价)) AND TS);
画柱线((收盘价 >= 开盘价),最低价,最高价,0.1,0),colorFF;
画柱线((收盘价 >= 开盘价),开盘价,收盘价,7,1),colorFF;
画柱线((收盘价 <= 开盘价),最低价,最高价,0.1,0),colorFFFF00;
画柱线((收盘价 <= 开盘价),开盘价,收盘价,7,0),colorFFFF00;
画柱线(((单阳 = 1) AND (周K < 50)),收盘价,开盘价,8,0),colorFFFF;
画柱线(((单阳 = 1) AND (周K < 50)),最高价,最低价,0,0),colorFFFF;
画柱线((单阳启稳 = 1),收盘价,开盘价,8,0),colorFF00FF;
画柱线((单阳启稳 = 1),最高价,最低价,0,0),colorFF00FF;
画柱线((((单阳 = 1) AND (周K > 50)) AND (周K < 80)),收盘价,开盘价,8,0),colorFFFF;
画柱线((((单阳 = 1) AND (周K > 50)) AND (周K < 80)),最高价,最低价,0,0),colorFFFF;
画柱线(((收盘价 >= 开盘价) AND (单阳攻击 = 1)),收盘价,开盘价,8,0),colorFF;
画柱线(((收盘价 >= 开盘价) AND (单阳攻击 = 1)),收盘价,开盘价,4,0),colorB0B0FF;
画柱线(((收盘价 >= 开盘价) AND (单阳攻击 = 1)),收盘价,开盘价,2,0),colorFFFF;
画柱线(((收盘价 >= 开盘价) AND (单阳攻击 = 1)),最高价,最低价,0,0),colorFFFF;
画柱线(((单阳 = 1) AND (周K >= 80)),收盘价,开盘价,8,0),colorFF2020;
画柱线(((单阳 = 1) AND (周K >= 80)),收盘价,开盘价,4,0),colorFF6600;
画柱线(((单阳 = 1) AND (周K >= 80)),收盘价,开盘价,2,0),colorFFFF00;
画柱线(((单阳 = 1) AND (周K >= 80)),最高价,最低价,0,0),colorFFFF00;
ZTZD:=最小值(向前引用(收盘价,1),最小值(向前引用(开盘价,1),最小值(向前引用(最高价,1),向前引用(最低价,1))));
ZTZG:=最大值(向前引用(收盘价,1),最大值(向前引用(开盘价,1),最大值(向前引用(最高价,1),向前引用(最低价,1))));
JTZD:=最小值(收盘价,最小值(开盘价,最小值(最高价,最低价)));
JTZG:=最大值(收盘价,最大值(开盘价,最大值(最高价,最低价)));
TKX:=(ZTZD > JTZG);
TKS:=(ZTZG < JTZD);

飞狐天空系列1号主图指标公式

 

相关文章