在线检测未来函数

通达信柱状VR资金指标公式

来源:Internet,编辑:股旁网,2012-05-31

N:=13;
HGY:=17;
×A??D?O?:FILTER(COUNT((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-
REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),
HGY),1))<REF((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,
HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1)),1),5)>=4
AND ((WINNER(C*0.95)>0.5 AND COST(85)<C AND (100*(EMA(EMA(EMA(C,HGY),
HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),
HGY),HGY),1))>0) OR ((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA
(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))>
REF((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),
HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1)),1) AND (100*(EMA(EMA(
EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/
REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))>0) OR ((100*(EMA(EMA(EMA(C,HGY),
HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),
HGY),HGY),1))<=0 AND (100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(
EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))>REF((
100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),
1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1)),1))),5),COLOR00FFFF;
STICKLINE(×A??D?O?,1,150,3,1),COLORRED,LINETHICK5;
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),26);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26);
VR:100*(TH*2+TQ)/(TL*2+TQ),NODRAW;
MAVR:MA(VR,10),NODRAW;
STICKLINE(VR>MAVR,0,VR,3,0),COLORRED;
STICKLINE(MAVR,0,MAVR,1,0),COLOR00FF00;
DRAWTEXT(CROSS(VR,250) AND VR>MAVR AND COUNT(VR<=300,21)=21,VR,'●加速'),COLOR00FFFF;
DRAWTEXT(CROSS(VR,MAVR) AND VR<=250 AND VR>=100 AND COUNT(MAVR<REF(MAVR,1),5)<5,VR,'●加仓'),COLOR00FFFF;
DRAWTEXT(CROSS(VR,400),VR,'●要小心'),COLOR00FFFF;
DRAWTEXT(CROSS(VR,MAVR) AND VR<=100,VR,'●底仓'),COLOR00FFFF;
{DRAWICON(MAVR>REF(MAVR,1) AND REF(MAVR,1)<REF(MAVR,2),MAVR,1);
DRAWICON(MAVR<REF(MAVR,1) AND REF(MAVR,1)>REF(MAVR,2),MAVR,2);};
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
短线:SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00,NODRAW;
中线:SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED,NODRAW;
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
长线:SMA(RSV3,5,1),COLORYELLOW,NODRAW;
看底:STICKLINE(中线<15,中线,15,6,0),COLORF00FF0;
黄金坑:STICKLINE(短线<20 AND 中线<20 AND 长线<20,MAX(长线,MAX(短线,中线)),20,8,0),COLOR00CCFF;
看顶:STICKLINE(中线>80,80,中线,6,0),COLORFFF000;
DRAWICON(CROSS(长线,15),中线,1),NODRAW;
DRAWTEXT(LONGCROSS(中线,20,15),20,'追涨'),NODRAW;
DRAWTEXT(CROSS(短线,长线)AND 长线<18 AND 长线>REF(长线,1)OR CROSS(长线,5),20,'千载难逢'),NODRAW;
{粘合星:DRAWTEXT(ABS(中线-长线)<2 AND 中线>REF(中线,1),中线,'*');}
中线2:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));
底:DRAWTEXT(CROSS(中线2,-90) AND (长线<中线 AND 长线>REF(长线,1)OR 短线<20 AND 中线<20 AND 长线<20),长线,'底'),COLORFF00FF,NODRAW;
IF(COUNT(CROSS(中线2,-90),12)=3,30,5),NODRAW;
IF(COUNT(CROSS(-5,中线2),12)=3 OR COUNT(CROSS(-15,中线2),6)=3,70,100),NODRAW;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
五强:=MA5>REF(MA5,1);
十强:=MA10>REF(MA10,1);
小均强:=五强 AND 十强;
强势线1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60);
强势线2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20);
强势线3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10);
强势线4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13);
开始走强1:=强势线1>REF(强势线1,1);
开始走强2:=强势线2>REF(强势线2,1);
开始走强3:=强势线3>REF(强势线3,1);
开始走强4:=强势线4>REF(强势线3,1);
双强1:=开始走强1 AND 开始走强2;
双强2:=开始走强2 AND 开始走强3;
双强3:=开始走强2 AND 开始走强3;
双强4:=开始走强3 AND 开始走强4;
三强:=开始走强1 AND 开始走强2 AND 开始走强3;
四强:=开始走强1 AND 开始走强2 AND 开始走强3 AND 开始走强4;
强势为王:=双强1 OR 双强2 OR 双强3 OR 双强4 OR 三强 OR 四强;
VV:=(C+L+H)/3;
DSA:=SMA(XMA(VV,15),2,1);
底部1:=DSA*0.9518;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
五日走强:=MA1>REF(MA1,1);
十日走强:=MA2>REF(MA2,1);
二十日走强:=MA3>REF(MA3,1);
六十日走强:=MA4>REF(MA4,1);
低位主升:=五日走强 AND 十日走强 AND 六十日走强;
主升浪:=五日走强 AND 十日走强 AND 二十日走强;
大主升浪:=十日走强 AND 二十日走强 AND 六十日走强;
大主升浪2:=五日走强 AND 十日走强 AND 二十日走强 AND 六十日走强;
总主升:=主升浪 AND 大主升浪 AND 大主升浪2;
总主升浪:=低位主升 OR 主升浪 OR 大主升浪 OR 大主升浪2 OR 总主升;
低买:L<底部1 AND 总主升浪 AND 强势为王 AND C<DSA,NODRAW,COLORGREEN,LINETHICK1;
STICKLINE(低买,0,15,3,0),COLORGREEN;
猎股:L<底部1 AND C<DSA AND 强势为王,NODRAW,COLORYELLOW,LINETHICK1;
STICKLINE(猎股,15,30,3,0),COLOR0078FF;
STICKLINE(猎股,15,30,0.3,0),,COLOR00F8FF;
猎股大王出击:=低买 AND 猎股 AND H<DSA;
A:=MA(C,30);
A1:=A*1.1;
A4:=A*0.9;
A2:=A1-(A1-A4)*0.191;
持仓:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A1,A4);
生命线:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A2,A4);
主升持仓:=持仓>生命线;
主升1:=持仓>REF(持仓,1);
主升2:=生命线>REF(生命线,1);
主升3:=主升1 AND 主升2;
主升猎股王:=(猎股大王出击 AND 主升持仓 AND 主升3) OR (猎股 AND 主升持仓 AND 主升3);
主升:(主升猎股王 AND 小均强) OR (猎股 AND 小均强),NODRAW,COLORMAGENTA,LINETHICK1;
STICKLINE(主升,30,45,3,0),COLORMAGENTA;
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
超跌1:=BIAS21<=-17 AND BIAS21<=REF(BIAS21,1);
阻击1:=REF(超跌1,1) AND BIAS21>REF(BIAS21,1);
BIAS20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
超跌2:=BIAS20<=-17 AND BIAS20<=REF(BIAS20,1);
阻击2:=REF(超跌2,1) AND BIAS20>REF(BIAS20,1);
BIAS19:=(CLOSE-MA(CLOSE,19))/MA(CLOSE,19)*100;
超跌3:=BIAS19<=-17 AND BIAS19<=REF(BIAS19,1);
阻击3:=REF(超跌3,1) AND BIAS19>REF(BIAS19,1);
BIAS18:=(CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100;
超跌4:=BIAS18<=-16 AND BIAS18<=REF(BIAS18,1);
阻击4:=REF(超跌4,1) AND BIAS18>REF(BIAS18,1);
BIAS17:=(CLOSE-MA(CLOSE,17))/MA(CLOSE,17)*100;
超跌5:=BIAS17<=-16 AND BIAS17<=REF(BIAS17,1);
阻击5:=REF(超跌5,1) AND BIAS17>REF(BIAS17,1);
BIAS16:=(CLOSE-MA(CLOSE,16))/MA(CLOSE,16)*100;
超跌6:=BIAS16<=-16 AND BIAS16<=REF(BIAS16,1);
阻击6:=REF(超跌6 ,1) AND BIAS16>=REF(BIAS16,1);
BIAS15:=(CLOSE-MA(CLOSE,15))/MA(CLOSE,15)*100;
超跌7:=BIAS15<=-14 AND BIAS15<=REF(BIAS15,1);
阻击7:=REF(超跌7,1) AND BIAS15>REF(BIAS15,1);
BIAS14:=(CLOSE-MA(CLOSE,14))/MA(CLOSE,14)*100;
超跌8:=BIAS14<=-14 AND BIAS14<=REF(BIAS14,1);
阻击8:=REF(超跌8,1) AND BIAS14>REF(BIAS14,1);
BIAS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
超跌9:=BIAS13<=-13 AND BIAS13<=REF(BIAS13,1);
阻击9:=REF(超跌9 ,1) AND BIAS13>REF(BIAS13,1);
BIAS12:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
超跌10:=BIAS12<=-13 AND BIAS12<=REF(BIAS12,1);
阻击10:=REF(超跌10,1) AND BIAS12>REF(BIAS12,1);
BIAS11:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;
超跌11:=BIAS11<=-13 AND BIAS11<=REF(BIAS11,1);
阻击11:=REF(超跌11,1) AND BIAS11>REF(BIAS11,1);
BIAS10:=(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*100;
超跌12:=BIAS10<=-12 AND BIAS10<=REF(BIAS10,1);
阻击12:=REF(超跌12,1) AND BIAS10>REF(BIAS10,1);
BIAS9:=(CLOSE-MA(CLOSE,9))/MA(CLOSE,9)*100;
超跌13:=BIAS9<=-12 AND BIAS9<=REF(BIAS9,1);
阻击13:=REF(超跌13,1) AND BIAS9>REF(BIAS9,1);
CD1:= 超跌1 OR 超跌2 OR 超跌3 OR 超跌4 OR 超跌5 OR 超跌6 OR 超跌7 OR 超跌8 OR 超跌9 OR 超跌10 OR 超跌11 OR 超跌12 OR 超跌13;
CD2:= 阻击1 OR 阻击2 OR 阻击3 OR 阻击4 OR 阻击5 OR 阻击6 OR 阻击7 OR 阻击8 OR 阻击9 OR 阻击10 OR 阻击11 OR 阻击12 OR 阻击13;
短线超跌:IF(CD1,18,0),COLORYELLOW;
短线超跌阻击:IF(CD2,28,0),COLORRED;
STICKLINE(短线超跌=18,18,0,3,0),COLOR00FFFF;
STICKLINE(短线超跌阻击=28,28,0,3,0),COLOR0000FF;
{www.gupang.com 股旁网_通达信股票指标公式}
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5);
AA1:IF(周J<=0 ,-4,0),COLOR00CCCC,LINETHICK3;
DRAWBAND(0,RGB(250,0,0),AA1,RGB(0,0,0));
T:=(CLOSE*1.0+LOW*0.0+HIGH*0.0);
SL:=(T/REF(T,1)-1)*1000;
快短期趋势:=XMA(XMA(XMA(SL,3),3),3);
慢短期趋势:=XMA(XMA(XMA(SL,5),5),5);
X1:=快短期趋势-慢短期趋势;
增速1:=X1;
Y:=X1;
趋势:=XMA(XMA(XMA(SL,29),29),29),COLORLIBLUE,LINETHICK1;
QW1:=趋势>REF(趋势,1);
趋势2:=XMA(XMA(XMA(SL,13),13),13),COLORMAGENTA,LINETHICK1;
QW2:=趋势>0;趋势3:=XMA(XMA(XMA(SL,9),9),9);
QW3:=趋势3>趋势;
QA6:=趋势2>REF(趋势2,1);
QA8:=((FILTER(ATAN(EMA(快短期趋势,13)-REF(EMA(快短期趋势,13),1))>1 AND
EMA(快短期趋势,13)>REF(EMA(快短期趋势,8),1),10)) AND QA6 AND QW2
AND (ZIG(3,12)>MA(ZIG(3,12),2))),NODRAW;
XG:QA8*10,COLORGREEN,NODRAW;
STICKLINE(XG,1,150,1.5,1),COLOR00ECFF,LINETHICK5;
DRAWTEXT(XG,148,'●MACD'),COLOR00ECFF;
DRAWTEXT(×A??D?O?,188,'●转强'),COLOR00FFFF;

通达信柱状VR资金指标公式

 

相关文章