在线检测未来函数

在主图MACD出现红柱 和WDIF金叉WDEA时分别作一个选股指标

来源:Internet,编辑:股旁网,2012-06-17

编写要求:

股旁网解答:

 网友求助:

高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=高1-(高1-低1)*0.5;
中轴:REFDATE(H3,DATE);
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=B1-B2;
WDIF:EMA(EMA(EMA(C,3),3),3)+B3;
WDEA:EMA(WDIF,9),COLORMAGENTA,LINETHICK2;
MACD:=2*(WDIF-WDEA);

STICKLINE(MACD>0,中轴,中轴+MACD,0,1),COLORRED;
STICKLINE(MACD<0,中轴,中轴+MACD,0,1),COLORLIBLUE;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR00BBFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR0011BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORBB11BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORFFBB11;

 

 

{DRAWTEXT(CROSS(MACDMA,MACD),HIGH*1.015,' 卖'),COLORFFFFCC;};
VARA:=LLV(LOW,36);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
趋势:= VARC, COLOR33FFFF;

顶背: STICKLINE(VARC>90,OPEN,CLOSE,3,0) , COLORRED;
VAR26:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR27:=MA(VAR26,5);
VAR28:=MA(VAR26,10);

 


{DRAWTEXT(CROSS(VAR26,VAR27) AND VAR27<VAR28,L*0.95,'▲争'),COLORYELLOW;}
STICKLINE(CROSS(VAR26,VAR27) AND VAR27<VAR28,OPEN,CLOSE,3,0),COLORYELLOW;
{DRAWTEXT(CROSS(VAR7,VAR6) AND VAR7>VAR8,VAR3*0.95,'夺'),COLORYELLOW;}
STICKLINE(CROSS(VAR27,VAR26) AND VAR27>VAR28,OPEN,CLOSE,3,0),COLORFF00FF;

VAR5:=EMA(MA(CLOSE,3),34);
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
DRAWTEXT(CC,L*0.98,'买!'),COLOR0099FF;
STICKLINE(CROSS(VAR1,VAR2) ,OPEN,CLOSE,3,0),COLORBB11BB;
AA2:=AMOUNT/V;
BB2:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,5)*0.921;
EE2:=V<MA(V,5)*1.5;
FF2:=BB2 AND CC2 AND DD2 AND EE2,LINETHICK0;
{DRAWTEXT(FF2,L*0.99,' 鼠'),COLORYELLOW;}

STICKLINE(FF2,O,C,4,0),COLORRED;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);

DRAWTEXT(CROSS(88,RSI),(HIGH * 1.0002),'↓'),COLOR1880FF;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
AAA:=2*E-LOW,NODRAW;
AB:=2*E-HIGH,NODRAW;
ACC:=E+(HIGH-LOW),NODRAW;
ADD:=E-(HIGH-LOW),NODRAW;
今阻力:REF(AAA,1),COLORWHITE,NODRAW;
今支撑:REF(AB,1),COLORYELLOW,NODRAW;
明阻力:AAA,COLORCYAN,NODRAW;
明支撑:AB,COLORMAGENTA,NODRAW;
明突破:ACC,COLORGREEN,NODRAW;
明反转:ADD,COLORLICYAN,NODRAW;

GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
今日阻力:REF(明日阻力 , 1),NODRAW;
今日支撑:REF(明日支撑 , 1),NODRAW;
STICKLINE(ISLASTBAR AND C>=今日阻力,今日阻力,今日阻力,10,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND C<今日阻力,今日阻力,今日阻力,10,1),COLOR00FF00;
STICKLINE(ISLASTBAR AND C>=今日支撑,今日支撑,今日支撑,10,1),COLORFF00FF;
STICKLINE(ISLASTBAR AND C<今日支撑,今日支撑,今日支撑,10,1),COLORFF8800;


STICKLINE(VARC>90 ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(VARC>90 ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(VARC>90 ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(VARC>90 ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(VARC>90 ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;

STICKLINE(VARC>90 ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;

网1:=MA(C,1);网5:=MA(C,5);

DRAWICON(CROSS(网1,网5),L,1);
DRAWICON(CROSS(网5,网1),H,2);

N:=30;
垂点:=REFDATE(HHV(H,N)/1.01,DATE);
DRAWTEXT(CURRBARSCOUNT=N,垂点,'微点防御'),COLORDDDD00;
{交易指示}
DATA:=5;
{多头买入} DRAWICON(ZIG(3,DATA)>REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)<=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)<=REF(ZIG(3,DATA),3),L*0.98,1);
{多头卖出} DRAWICON(ZIG(3,DATA)<REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)>=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)>=REF(ZIG(3,DATA),3),H*1.02,2);

 

在主图MACD出现红柱 和WDIF金叉WDEA时分别作一个选股指标

解答如下:
第一个
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=B1-B2;
WDIF:=EMA(EMA(EMA(C,3),3),3)+B3;
WDEA:=EMA(WDIF,9),COLORMAGENTA,LINETHICK2;
MACD:=2*(WDIF-WDEA);
OK:MACD>REF(MACD,1)AND MACD<0;
第二个
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=B1-B2;
WDIF:=EMA(EMA(EMA(C,3),3),3)+B3;
WDEA:=EMA(WDIF,9);
OK:CROSS(WDIF,WDEA);
 

 

相关文章