在线检测未来函数

通达信改良主力追踪指标公式

来源:Internet,编辑:股旁网,2012-07-01

V1:=(C*3+H+L)/5*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
0;
主力动向:EMA(V4,2),COLORRED;
机构动向:EMA(VB,2),COLORMAGENTA;
{www.gupang.com 股旁网_通达信股票指标公式}
(SLOPE(主力动向,2)>0 AND SLOPE(机构动向,2)>0,主力动向),COLORRED,LINETHICK4;
(SLOPE(主力动向,2)<0,主力动向),COLORGREEN,LINETHICK3;
(SLOPE(机构动向,2)>0 AND SLOPE(主力动向,2)>0,机构动向),COLORMAGENTA,LINETHICK4;
(SLOPE(机构动向,2)<0,机构动向),COLORWHITE,LINETHICK2;
ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,89);
ZJLRQD:=ZZLKP-ZZLJJ;
AA:=EMA(ZJLRQD,1);
BB:=EMA(AA,5);
CC:=AA-BB;
STICKLINE(CC<REF(CC,2),CC,0,5,1), COLOR00FF00;
STICKLINE(CC>REF(CC,2),CC,0,5,1), COLORRED;
主力资金试盘:IF(CROSS(AA,BB),3,0),STICK,LINETHICK4,COLOR0080FF;
主力对倒出货:IF(CROSS(BB,AA),-3,0),STICK,LINETHICK4,COLOR00FF00;
DRAWICON(主力资金试盘>0,5,4);
DRAWICON(主力对倒出货<0,-4,2);
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),5);
惨跌:STICKLINE(VAR5>REF(VAR5,1),0,VAR5,7,0 ),COLORMAGENTA;
主力拉升:STICKLINE(VAR5<REF(VAR5,1),0,VAR5,7,0),COLORRED;{红}
洗盘阴:STICKLINE(VAR5<REF(VAR5,1) AND C<O,0,VAR5,7,0),COLORBLUE;

通达信改良主力追踪指标公式

 

相关文章