在线检测未来函数

通达信买卖指示灯指标公式

来源:Internet,编辑:股旁网,2012-07-09

VAR3:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VAR4:=SMA(SMA(VAR3,3,1),3,1);
VAR5:=EMA(VAR4,5);
VAR6:=VAR5;
VAR7:=3*VAR4-2*VAR5;
VAR8:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K: SMA(VAR8,3,1), , COLORRED;
D: SMA(K,3,1), , COLORYELLOW;
VAR9:=3*K-2*D;
VARA:=LLV(LOW,36);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
趋势: VARC, ,COLOR00FF00;
底背: STICKLINE(VARC<10,0,8,5,0), , COLORYELLOW;
顶背: STICKLINE(VARC>90,100,92,5,0), , COLORRED;
VARD:=87.5;
VARE:=(VARC-LLV(VARC,4))/(HHV(VARC,4)-LLV(VARC,4))*4*25;
反弹: DRAWTEXT(IF(CROSS(VAR9,8),87,0),48,'反弹'), , COLORF0F000;
{www.gupang.com 股旁网_通达信股票指标公式}
买: DRAWTEXT(IF(CROSS(VARE,87.5) AND 趋势<40,87,0),10,'买'), , COLOR00FF00;
目标位: DRAWTEXT(IF(CROSS(趋势,VARD) AND VARE=100,50,0),56,'目标位'), , COLORBLUE;
见好跑: DRAWTEXT(IF(CROSS(VARD,趋势),87,0),85,'见好跑'), , COLORF00FF0;
卖: DRAWTEXT(IF(CROSS(趋势,VARE) AND 趋势>87,87,0),70,'卖'), , COLORRED;
短买: IF(CROSS(趋势,10) AND 趋势>10,50,0), STICK,LINETHICK3, COLORGREEN;
VARF:=SMA(VAR3,20,1);
VAR10:=SMA(VARF,15,1);
VAR11:=(3*VARF+2*VAR10)/4;
VAR12:=REF(VAR11,1);
VAR13:=SMA(MAX(VAR11-VAR12,0),2,1)/SMA(ABS(VAR11-VAR12),2,1)*100;
VAR14:=MA(VAR13,10);
VAR15:=IF(CROSS(VAR14,90),25,0);
DRAWTEXT(CROSS(VAR14,90),27,'强势整理'), , COLORWHITE;
VAR16:=(CLOSE+LOW+HIGH)/3;
VAR17:=SUM((VAR16-REF(LOW,1)-(HIGH-VAR16))*VOL/100000/(HIGH-LOW),0);
VAR18:=EMA(VAR17,1);
VAR19:=MA(VAR18,12);
VAR1A:=MA(VAR18,26);
VAR1B:=(VAR18-VAR19)*10;
VAR1C:=CAPITAL/EMA(VOL,5)/30*1.1;
VAR1D:=IF(CROSS(VAR1B,VAR1C),1,0);
VAR1E:=FILTER(VAR1D,7);
VAR1F:=DRAWICON(VAR1E=1,100,1);
VAR20:=EMA(CLOSE,12)-EMA(CLOSE,26);
强势: DRAWTEXT(IF(CROSS(VAR20,0) AND VAR20>0,87,0),80,'强势'), , COLORRED;
弱势: DRAWTEXT(IF(CROSS(0,VAR20) AND VAR20<0,87,0),15,'弱势'), , COLORYELLOW;
VAR21:=(CLOSE*2+HIGH+LOW)/4;
VAR22:=EMA(VAR21,12)-EMA(VAR21,26);
VAR23:=EMA(VAR22,2);
VAR24:=2*(VAR22-VAR23)*5.8;
加仓: DRAWTEXT(IF(CROSS(VAR24,0.47),LOW,0),12,'加仓'), , COLOR00FF00;
VAR25:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VAR26:=66.6;
DRAWTEXT(IF(CROSS(VAR25,63) AND CROSS(VAR9,D) OR CROSS(VAR25,76) AND CROSS(VAR9,D) OR CROSS(VAR25,80) AND CROSS(VAR9,D) OR CROSS(VAR25,85) AND CROSS(VAR9,D),LOW,0),20,'反弹'), , COLORF00FF0;

通达信买卖指示灯指标公式

 

相关文章