在线检测未来函数

大智慧均线+涨跌停提示+重心提示+九日价画线主图指标公式

来源:Internet,编辑:股旁网,2012-07-21

input:P1(5,1,1000),P2(10,1,1000),P3(20,1,1000),P4(30,1,1000),P5(60,1,1000),P6(120,1,1000);
MA1:MA(CLOSE,P1);
MA2:MA(CLOSE,P2);
MA3:MA(CLOSE,P3);
MA4:MA(CLOSE,P4);
MA5:MA(CLOSE,P5);
MA6:MA(CLOSE,P6);
DRAWTEXT( BARSTATUS=2,MA1 ,'五日均线' ),Color00ffff;
DRAWTEXT( BARSTATUS=2,MA2 ,'十日均线' ),Color00ffff;
DRAWTEXT( BARSTATUS=2,MA3 ,'二十日均线' ),colorred,LAYER6;
DRAWTEXT( BARSTATUS=2,MA4 ,'三十日均线' ),Colorff0000,LAYER6;
DRAWTEXT( BARSTATUS=2,MA5 ,'六十日均线' ),colorred,LAYER6;
DRAWTEXT( BARSTATUS=2,MA6 ,'一百二十日均线' ),colorred,LAYER6;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,5,0),COLORYELLOW,LINETHICK5;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,5,0),COLORBLUE,LINETHICK5;
{www.gupang.com 股旁网_大智慧股票指标公式}
QQ:=(C-REF(C,1))/REF(C,1)*100<-7.9;
STICKLINE(QQ,OPEN,CLOSE,2,0),COLORBLUE,LINETHICK4;
重心:=AMOUNT/(V*100);
两日重心:=(SUM(AMOUNT,2))/(SUM((V*100),2));
三日重心:=(SUM(AMOUNT,3))/(SUM((V*100),3));
四日重心:=(SUM(AMOUNT,4))/(SUM((V*100),4));
上日重心:=ref(重心,1);
上两日重心:=ref(两日重心,1);
上三日重心:=ref(三日重心,1);
上四日重心:=ref(四日重心,1);
前日重心:=ref(重心,2);
前两日重心:=ref(两日重心,2);
前三日重心:=ref(三日重心,2);
前四日重心:=ref(四日重心,2);
DRAWTEXTREL(0,100,'■今日重心:'+重心),COLORGREEN;
DRAWTEXTREL(85,100,'■两日重心:'+两日重心),COLOR0099ef;
DRAWTEXTREL(0,150,'■三日重心:'+三日重心),COLORGREEN;
DRAWTEXTREL(85,150,'■四日重心:'+四日重心),COLOR0099ef;
DRAWTEXTREL(185,100,'■上日重心:'+上日重心),COLORGREEN;
DRAWTEXTREL(270,100,'■上两日重心:'+上两日重心),COLOR0099ef;
DRAWTEXTREL(185,150,'■上三日重心:'+上三日重心),COLORGREEN;
DRAWTEXTREL(270,150,'■上四日重心:'+上四日重心),COLOR0099ef;
DRAWTEXTREL(370,100,'■前日重心:'+前日重心),COLORGREEN;
DRAWTEXTREL(455,100,'■前两日重心:'+前两日重心),COLOR0099ef;
DRAWTEXTREL(370,150,'■前三日重心:'+前三日重心),COLORGREEN;
DRAWTEXTREL(455,150,'■前四日重心:'+前四日重心),COLOR0099ef;
STICKLINE(BARSTATUS=2 ,(HHV(H,9)+LLV(L,9))/2,(HHV(H,9)+LLV(L,9))/2,225,0),COLOR2233FF;

大智慧均线+涨跌停提示+重心提示+九日价画线主图指标公式

 

相关文章