在线检测未来函数

把资金进场,上升通道,改成飞狐公式选股公式

来源:Internet,编辑:股旁网,2012-07-15

编写要求:

求助老师把资金进场,上升通道,改成飞狐公式选股公式 VAR3ggg:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1)); VAR4ggg:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1)); T7qq:=VAR3ggg>REF(VAR4ggg,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1); B7qq:DRAWTEXT(T7qq AND COUNT(T7qq,30)=1,70,'↖资金进场!'),COLORYELLOW; VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VAR2:=2*ABS(VAR1); 多方:=IF(VAR1>0,VAR1,0),LINESTICK; 空方:=-IF(VAR1<0,VAR2,0),LINESTICK; T1:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1); DRAWTEXT(T1 AND COUNT(T1,30)=1,90,'↖上升通道!'),colorFFFF;

股旁网解答:

 var3ggg:=100-(100-3*sma((close-llv(low,55))/(hhv(high,55)-llv(low,55))*100,20,1)+2*sma(sma((close-llv(low,55))/(hhv(high,55)-llv(low,55))*100,20,1),15,1));

var4ggg:=100-(100-3*sma((open-llv(low,55))/(hhv(high,55)-llv(low,55))*100,20,1)+2*sma(sma((open-llv(low,55))/(hhv(high,55)-llv(low,55))*100,20,1),15,1));
t7qq:=var3ggg>ref(var4ggg,1) and vol>ref(vol,1) and close>ref(close,1);
资金进场:t7qq and count(t7qq,30)=1;
 
 
 
 
var1:=ma(100*(close-llv(close,34))/(hhv(high,34)-llv(low,34)),5)-20;
var2:=2*abs(var1);
多方:=if(var1>0,var1,0);
空方:=-if(var1<0,var2,0);
t1:=close>ma(close,20) and ma(close,20)>=ref(ma(close,20),1);
上升通道:t1 and count(t1,30)=1;

相关文章