在线检测未来函数

通达信云端多指标共振主图指标公式

来源:Internet,编辑:股旁网,2012-09-11

C2:=REF(C,1);
BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};
BG2:=IF((H-L)*100/C2>=3.58,1,0);
BB1:=L<REF(L,1);
SELL1:=BG AND BB1 ;
BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);
STICKLINE(BR,O,C,3,0),COLORRED;
DAY1:=BARSLAST(SELL1);
JIA1:=REF(O,DAY1);
JIA2:=REF(O,1);
BB4:=C>JIA2;
BB2:=H>JIA1;
BUY1:=BR AND BB2 AND BB4;
DAY2:=BARSLAST(BUY1);
S1:=DAY1<DAY2;
B1:=DAY2<DAY1;
STICKLINE(S1,O,C,3,0),COLORLIGREEN;
STICKLINE(B1,H,L,0.3,0),COLORRED;
STICKLINE(B1,O,C,3,1),LINETHICK2,COLORRED;
AA2:=AMOUNT/VOL;
BB3:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,6)*0.921;
DD1:=L<MA(C,5)*0.921;
EE2:=VOL<MA(V,5)*1.5;
FF2:=BB3 AND CC2 AND DD2 AND EE2;
STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF;
B4:=BARSLAST(FF2);
E4:=B4<5;
F4:=E4 AND C>REF(C,1);
STICKLINE(F4,H,L,0.3,0),COLOR00FFFF;
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
DRAWTEXT(AA,H*1.06,'*警'),COLORGREEN;
STICKLINE(AA,H,L,0.3,0),COLORFF0000;
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ;
DRAWICON(CCC,L*0.99,1);
STICKLINE(CC,H,L,0.3,0),COLORRED;
STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;
CF1:=BARSLAST(CC);
CF2:=CF1<3;
CF3:=CF2 AND C>REF(C,1);
STICKLINE(CF3,O,C,3,0),COLORYELLOW;
CD:=CROSS(VAR2,VAR1);
STICKLINE(CD,H,L,0.3,0),COLORYELLOW;
STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;
DRAWTEXT(CD,H*0.93,'*预警'),COLORRED;
DRAWTEXT(CC,L*0.97,'*买'),COLORFF00FF;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.94),'*进 '),COLORRED;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'*加仓'),COLORRED;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;
DRAWTEXT_FIX(1,0.88,5,0,'~☆~云在云端作品~☆~'),COLORMAGENTA;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.02,'*警'),COLORYELLOW;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)<A5A,L*0.98,'*黑马'),COLORYELLOW;
多:=EMA(C,3);
空:=EMA(C,5);
均衡:=EMA(空,5);
VVARF1:=COUNT(CROSS(多,均衡),2)=1;
VVARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VVARF1 AND VVARF2,2);
DRAWTEXT(ZAI,均衡*0.985,'*追'),COLORRED;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VVARR1),HIGH,2);
DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW;
VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VVAR2:=REF(VVAR1,1);
{www.gupang.com 股旁网_通达信股票指标公式}
VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;
HY3:=IF(COUNT(VVAR3<20,5)>=1 AND COUNT(VVAR1=LLV(VVAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,' *预警'),COLORRED;
ZA1:=EMA(C,25);
ZA2:=EMA(ZA1,45);
ZB1:=EMA(C,65);
ZB2:=EMA(ZB1,45);
DIFF:=(ZA1+ZB2)/2;
DEA:=(ZA2+ZB1)/2;
KA0:=(HHV(C,45)-LLV(C,45))/45;
KA1:=SMA(C,3,1);
KA2:=SMA(C-KA0*3,3,1);
KA3:=SMA(KA1-KA0*3,3,1);
SC:=100*(CLOSE-MA(CLOSE,80));
SC1:=EMA(SC,5);
SC2:=EMA(SC,21);
长期策略:SC1>=SC2,NODRAW;
中期策略:DIFF>=DEA,NODRAW;
短期策略:KA2>=KA3,NODRAW;
中期趋势:DIFF,NODRAW;
短期趋势:KA2,NODRAW;
短期拐点:REF(短期策略,1)=0 AND 短期策略=1,NODRAW;
长期趋势:ZB2,COLORBLUE,LINETHICK3;
IF(DIFF>=DEA,DIFF,DRAWNULL),LINETHICK2,COLORRED;
IF(DIFF<DEA,DIFF,DRAWNULL),LINETHICK1,COLORLICYAN;
IF(KA2>=KA3,KA2,DRAWNULL)COLORMAGENTA,LINETHICK2;
IF(KA2<KA3,KA2,DRAWNULL),LINETHICK1,COLORGREEN;
DRAWTEXT(ISLASTBAR,长期趋势,'*长期趋势'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,中期趋势,'*中期趋势'),COLORRED;
DRAWTEXT(ISLASTBAR,短期趋势,'*短期趋势'),COLORYELLOW;

通达信云端多指标共振主图指标公式

 

相关文章