载入中...
在线检测未来函数
载入中...

同花顺薛斯通道及突破量系统主图指标公式

来源:Internet,编辑:股旁网,2012-09-01

N:=5;M:=3;
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:AA*N/100,LINETHICK2;
通道2:AA*(200-N)/100,LINETHICK2;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:(1+M/100)*DD,LINETHICK2;
通道4:(1-M/100)*DD,LINETHICK2;
二分位:(H+L)/2 ,LINETHICK2,colorgreen,POINTDOT;
VAR1:=MA(CLOSE,3);
FF:=VAR1>REF(VAR1,1);
PARTLINE(Var1,FF,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK1;
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,5,0),COLORFF00FF;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9,C,'---------BIAS底买'),colorgreen;
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离>3,C,'---------BIAS顶'),colorblue;
aa:=CLOSE > REF(CLOSE, 1) AND REF(CLOSE, 1) > REF(CLOSE, 2) AND REF(CLOSE, 1) < REF(CLOSE, 3) AND IF(REF(CLOSE, 3) < REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) < REF(CLOSE, 5),REF(CLOSE, 1) < REF(CLOSE, 4) OR( REF(CLOSE, 2) < REF(CLOSE, 4) AND REF(CLOSE, 3) >= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) < REF(CLOSE, 6), 1,REF(CLOSE, 6) < REF(CLOSE, 7))));
bb:=CLOSE < REF(CLOSE, 1) AND REF(CLOSE, 1) < REF(CLOSE, 2) AND REF(CLOSE, 1) > REF(CLOSE, 3) AND IF(REF(CLOSE, 3) > REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) > REF(CLOSE, 5),REF(CLOSE, 1) > REF(CLOSE, 4) OR( REF(CLOSE, 2) > REF(CLOSE, 4) AND REF(CLOSE, 3) <= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) > REF(CLOSE, 6), 1,REF(CLOSE, 6) > REF(CLOSE, 7))));
DRAWTEXT(aa AND CLOSE>REF(OPEN,2),LOW,'三平底'),color,COLORFF00FF;
DRAWTEXT(bb AND CLOSE<REF(CLOSE,2),HIGH,'三平顶'),color00ff00;
S下:=HHV(MA(HIGH,2),2),colorgreen,LINETHICK0;
S上:=LLV(MA(HIGH,2),1),colorred,LINETHICK0;
Sppp:=-(S上-S下)/REF(C,1)*100;
Sptem1:=(MIN(O,C)-L)/(H-L)*100;
Sptem2:=(H-MAX(O,C))/(H-L)*100;
SPTEM3:=(C-O)/(H-L)*100;
SKJ1:=(SPTEM3>49 AND SPTEM1>0.3*SPTEM2) OR SPTEM3>80;
SKJ2:=(SPTEM3<=49 AND SPTEM3>20 AND SPTEM1>SPTEM2);
SKJ3:=(SPTEM3<=20 AND sptem3>-20 AND sptem1>1.2*sptem2);
SKJ4:=(SPTEM3<-20 AND SPTEM3>-40 AND SPTEM1>2*SPTEM2);
SKJ:=(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4) AND (Sppp>2 OR REF(Sppp,1)>2 );
短买:=IF(SUM(sppp>0,5)=5 AND SUM(skj>0,5)=0,5*(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4),5*skj),colorred;
DRAWTEXT(短买,L,'↖短买'),colorwhite;
x1:=(C+L+H)/3;
bb13:=ATAN(EMA(x1,13)-REF(EMA(x1,13),1))*3.1416*10;
ema8:=EMA(C,8);
DRAWTEXT(FILTER(bb13>1 AND EMA(x1,13)>REF(EMA(x1,8),1),10),
ema8,'∠45'),colorwhite;
STICKLINE(C>=COST(50)AND C<=COST(58)AND C>O,O,C,5,0),colorred;
STICKLINE(C>=COST(97)AND C<=COST(100)AND C>O,O,C,5,0),colorwhite;
DRAWTEXT(C>=COST(97)AND C<=COST(100) AND C>O,C,'-->97%'),colorred;
DRAWTEXT(C>=COST(50)AND C<=COST(58) AND C>O,C,'--50%'),coloryellow;
//{www.gupang.com 股旁网_同花顺股票指标公式}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
买入线:=IF(CROSS(K,15),100,0);
DRAWTEXT(买入线,L,'←KD底'),colorff00ff;
买出线:=IF(CROSS(K,80),100,0);
DRAWTEXT(买出线,H,'←KD顶'), colorwhite ;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
买入线:=IF(CROSS(RSI1,20),100,0);
DRAWTEXT(买入线,L,'←RSI底'), colorred ;
买出线:=IF(CROSS(RSI1,80),100,0);
DRAWTEXT(买出线,H,'←RSI顶'),colorcyan;
WR:="W&R"(14);
DRAWICON(FILTER(CROSS(WR,(0 - 81)),10),L,4);//威廉买点↑ ↓
DRAWICON(FILTER(CROSS((0 -19),WR),10),H,5);//威廉卖点
DRAWTEXT(FILTER(CROSS(WR,(0 - 81)),21),L,'威廉买'),ALIGN0,colorred;//威廉买点
DRAWTEXT(FILTER(CROSS(0 -19,WR),21),H,'威廉卖'),ALIGN2,colorgreen;//威廉卖点
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
买入线:=IF(CROSS(CCI,-160),100,0);
DRAWTEXT(买入线,L,'←CCI底'),COLOR0099FF ;
买出线:=IF(CROSS(CCI,200),100,0);
DRAWTEXT(买出线,H,'←CCI顶'),coloryellow ;
Var3:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
Var4:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
Var5:=Var3 AND Var4;
DRAWTEXT(Var5,LOW,'★ '),coloryellow , ;
极品底:=IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,50,0),colorwhite;
DRAWTEXT(极品底=50,LOW,'★ ');
DRAWTEXT(V>=REF(V*1.88,1) AND C>O AND C>REF(C,1),O,'←---突量-------------------------------------------------------------------------------------'),coloryellow;
DRAWTEXT(V>=REF(V*1.88,1) AND C<O AND C<REF(C,1),O,'←---跌量-------------------------------------------------------------------------------------'),colorblue;
DRAWTEXT(LLV(VOL,13)=VOL AND C>=REF(C,1),O,'缩量'),coloryellow;
AA0:=SUMBARS(VOL,CAPITAL);
DRAWTEXT(IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,AA0)/3),L,'地量'),colormagenta;

同花顺薛斯通道及突破量系统主图指标公式

 

同花顺薛斯通道及突破量系统主图指标公式的选股公式如下:

相关文章