在线检测未来函数

旧版通达信的指标在新下载的通达信软件上显示

来源:Internet,编辑:股旁网,2012-09-18

编写条件:

旧版通达信上的指标在新下载的通达信上不能显示或只显示一部分。请老师帮忙解决一下或帮忙修改一下指标公式。在下不胜感激!谢谢!!!! 比如kdj日月周金叉共振指标。 月K:"KDJ.K#MONTH",COLOR0080FF; 月D:"KDJ.D#MONTH",COLOR0080FF,LINETHICK2; 周K:"KDJ.K#WEEK",COLORRED; 周D:"KDJ.D#WEEK",COLORRED,LINETHICK2; 日K:"KD.K",COLORWHITE; 日D:"KD.D",COLORWHITE,LINETHICK2; 日金叉:IF(CROSS(日K,日D),20,0),COLORWHITE; 周金叉:IF(CROSS(周K,周D),40,0),COLORRED; 月金叉:IF(CROSS(月K,月D),60,0),COLOR0080FF; DRAWICON(周金叉 AND 日金叉,5,15); DRAWICON(周金叉 AND 月金叉,8,11); DRAWICON(日金叉 AND 月金叉,13,17); 还有分时决策指标,旧版可显示四条线而新版只显示两条线

编写方法:

 

 
A1:=(VOL/CLOSE)/3;
A2:=SUM((IF(((A1>29) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A3:=SUM((IF(((A1>29) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
A4:=SUM((IF(((A1<29) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A5:=SUM((IF(((A1<29) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
机构买盘:(A2),LINETHICK3,COLORFF55FF;
机构卖盘:(A3),LINETHICK3,COLORFFFF00;
散户买盘:(A4),COLOR5555FF;
散户卖盘:(A5),COLOR55FF55;
DRAWTEXT(ISLASTBAR=1,机构买盘*0.9,'机构买盘'),LINETHICK2,COLORFF55FF;
DRAWTEXT(ISLASTBAR=1,机构卖盘,'机构卖盘'),LINETHICK2,COLORFFFF55;
DRAWTEXT(ISLASTBAR=1,散户买盘,'散户买盘'),LINETHICK2,COLOR5555FF;
DRAWTEXT(ISLASTBAR=1,散户卖盘,'散户卖盘'),LINETHICK2,COLOR55FF55;
 

相关文章