在线检测未来函数

通达信布林买卖主图指标公式

来源:Internet,编辑:股旁网,2012-10-19

MA5:EMA(CLOSE,5);
MA10:EMA(C,13);
MA20:EMA(CLOSE,21);
VAR1:=(REF(HIGH,1)+REF(LOW,1))/2;
压力线:MA(CLOSE,21)+2*STD(CLOSE,21);
支撑线:MA(CLOSE,21)-2.2*STD(CLOSE,21),COLORFF0000;
VAR2:=CROSS(VAR1,压力线);
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),7,1)/SMA(ABS(CLOSE-VAR3),7,1)*100;
VAR5:=CROSS(79,VAR4);
VAR6:=FILTER(VAR5,4);
DRAWICON(FILTER(VAR6 OR VAR2,5),HIGH*1.035,2);
DRAWTEXT(FILTER(VAR6 OR VAR2,5),HIGH*1.02,'卖观注'),COLORYELLOW;
VAR7:=FILTER( MA5>REF(MA5,1)AND MA10>REF(MA10,1)AND MA20>REF(MA20,1)AND MA5<MA10,5);
VAR8:=FILTER(HHVBARS(H,13)/C>2 AND MA5>REF(MA5,1)AND MA5<MA10,7);
{ Gupang.com 股-旁-网_通达信股票指标公式}
VAR9:=REF(L,2)<支撑线 AND L>支撑线 AND C>O AND MA5>REF(MA5,1);
DRAWICON(FILTER(VAR7 OR VAR8 OR VAR9,5)AND VAR4<45,L,1);
DRAWTEXT(FILTER(VAR7 OR VAR8 OR VAR9,5)AND VAR4<45,L,'买观注'),COLORRED;
DRAWICON(CROSS(10,VAR4),L,10);
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,L,'金印'),COLORRED;

通达信布林买卖主图指标公式

 

相关文章