在线检测未来函数

通达信融胜MACD指标公式

来源:Internet,编辑:股旁网,2012-10-17

VAR1:=REF(MA(C,20),10);
开:=O-VAR1;高:=H-VAR1;
低:=L-VAR1;收:=C-VAR1;
MID:=MA(C,20);
UPPER:=MID+2*STD(C,20);
LOWER:=MID-2*STD(C,20);
V1:=(C-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);
K1:=SUM(LLV(V2,4),4)/4;
V3:=EMA(V2,64)*10;
V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;B:=V2>V4;D:=V5>10;E:=V3<=10 OR V2<=V4 OR V5<=10;
STICKLINE(C,0,0,6,0), COLORYELLOW;
STICKLINE(收>=开 AND E,高,低,0,0), COLORRED;
STICKLINE(收>=开 AND E,收,开,3,0) ,COLORRED;
STICKLINE(收< 开 AND E,高,低,0,0) ,COLORGREEN;
STICKLINE(收< 开 AND E,收,开,3,0) ,COLORGREEN;
STICKLINE(开> 收 AND A ,低,高,0,0),COLORFF0000;
STICKLINE(开> 收 AND A ,收,开,3,0),COLORFF0000;
STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开<=收 AND A,收,开,3,1),COLORYELLOW;
STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;
STICKLINE(开> 收 AND B,收,开,3,0),COLORRED;
STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;
STICKLINE(开<=收 AND B,收,开,3,1),COLORRED;
STICKLINE(开> 收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开> 收 AND D,收,开,3,0),COLORGREEN;
STICKLINE(开<=收 AND D,收,开,3,1),COLORGREEN;
长DIF:EMA(CLOSE,7)-EMA(CLOSE,144),LINETHICK1;
长DEA:EMA(长DIF,360),LINETHICK1;
JC:=CROSS(长DIF,长DEA);
DRAWBAND(长DIF,RGB(150,0,150),长DEA,RGB(0,100,200));
{ Gupang.com 股-旁-网_通达信股票指标公式}
F:=(EMA(CLOSE,5)-EMA(CLOSE,21))*4;
Z:=EMA(F,5);
MMD:=2*(F-Z);
STICKLINE(MMD>0,0,MMD,0.1,0),COLOR0000FF;
STICKLINE(MMD<0,0,MMD,0.1,0),COLOR00FF00;
短DIF:F,COLORFFFFFF;
短DEA:Z,COLORGREEN,LINETHICK1;
短DEA降:IF(短DEA<REF(短DEA,1),短DEA,DRAWNULL),COLORRED,LINETHICK1;
{PARTLINE(A,A>F,RGB(255,0,0),A<F,RGB(0,255,0),1,RGB(0,0,255));};
{DRAWBAND(短DIF,RGB(255,0,0),短DEA,RGB(0,0,255));};

通达信融胜MACD指标公式

 

相关文章