在线检测未来函数

通达信云端三平底主图指标公式

来源:Internet,编辑:股旁网,2012-10-18

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXT_FIX(1,0,0.10,0,'【量能饱和度】')COLORRED;
DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(SAT)),COLORYELLOW;
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)<0 OR REF(SS,1)>0 ,REF(SS,1),IF(REF(SS,2)>0 OR REF(SS,2)<0,REF(SS,2),IF(REF(SS,3)<0 OR REF(SS,3)>0,REF(SS,3),IF(REF(SS,5)<0 OR REF(SS,5)>0,REF(SS,5),IF(REF(SS,6)<0 OR REF(SS,6)>0,REF(SS,6),IF(REF(SS,7)<0 OR REF(SS,7)>0,REF(SS,7),0))))));
TOW1:=IF(C>REF(C, 1), C,REF(C, 1)),POINTDOT,COLORWHITE;
TOW2:=IF((SS=-1 OR SS=-2) AND SM>0, B2,TOW1),POINTDOT,COLORWHITE;
TOWER:=IF(TOW1>TOW2, TOW1,TOW2),POINTDOT,COLORWHITE;
STICKLINE(CLOSE>=REF(C,1),CLOSE,REF(C,1),3,1),COLORRED;
STICKLINE(CLOSE<REF(C,1),CLOSE,REF(C,1),1,0),COLORGREEN;
STICKLINE(REF(C,1)>=REF(C,2) AND CLOSE<REF(C,1),REF(C,1),MAX(REF(C,2),CLOSE),3,1),COLORRED;
STICKLINE(REF(C,1)<REF(C,2) AND CLOSE>=REF(C,1),REF(C,1),MIN(REF(C,2),CLOSE),4,0),COLORFF0080;
LC:=REF(C,1);
LC2:=REF(C,2);
平底:=LC<LC2&&C>=LC;
收阳:=C>O;
DRAWLINE(平底 AND 收阳,L{最低价},REF(平底 AND 收阳,1),REF(L,1),1),COLORYELLOW,LINETHICK2;
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR656500;
STICKLINE(C<O,C,O,2.5,0),COLOR757500;
STICKLINE(C<O,C,O,2,0),COLOR858500;
STICKLINE(C<O,C,O,1.5,0),COLOR959500;
STICKLINE(C<O,C,O,1,0),COLORA5A500;
STICKLINE(C<O,C,O,0.5,0),COLORB5B500;
STICKLINE(C<O,H,L,0,0),COLORC5C500;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
持股:STICKLINE(A>B,A,B,2,0),COLORYELLOW;
持币:STICKLINE(A<B,A,B,2,0),COLORBLUE;
A11:=(REF(EMA(CLOSE,5),1));
B21:=CROSS(EMA(CLOSE,5),EMA(SLOPE(CLOSE,21)*20+CLOSE,42));
DRAWTEXT(B21,LOW*0.995,'*追'),COLORCYAN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWTEXT(CROSS(J,D),LOW*0.98,'*加'),COLORYELLOW;
X6:=REF(CLOSE,1);
X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);DRAWTEXT(X9,HIGH*1.01,'*警'),COLORGREEN;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,3.15,0),COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,2.45,0),COLOR339999;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.75,0),COLOR33BBBB;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.05,0),COLOR33DDDD;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,0.35,0),COLOR33FFFF;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*0.98,'*地'),COLORRED;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5);
VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,3.15,0),COLOR770077;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,2.45,0),COLOR990099;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.75,0),COLORBB00BB;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.05,0),COLORDD00DD;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,0.35,0),COLORFF00FF;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L*0.99,'*吸'),COLORMAGENTA;
{ Gupang.com 股-旁-网_通达信股票指标公式}
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
少量买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,少量买,'*少量买'),COLORCYAN;
AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));
BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AA AND CLOSE>REF(OPEN,2),LOW*0.96,'*平'),COLORRED;
DRAWTEXT(BB AND CLOSE<REF(CLOSE,2),HIGH*1.02,'*平'),COLORGREEN;

通达信云端三平底主图指标公式

 

相关文章