在线检测未来函数

通达信切线主图指标公式

来源:Internet,编辑:股旁网,2012-10-18

DRAWLINE(L=LLV(L,3),L,C=HHV(C,3),L,0),COLOR9A90FF;
趋势射线7: DRAWLINE(H=HHV(H,7),H,L=LLV(L,7),L,0),COLOR9AFF89;
射线7X: DRAWLINE(L=LLV(L,7),L,H=HHV(H,7),L,0),COLOR9AFF89;
趋势射线21: DRAWLINE(H=HHV(H,21),H,L=LLV(L,21),L,0),COLORC100FF;
射线21X: DRAWLINE(L=LLV(L,21),L,H=HHV(H,21),L,0),COLORC100FF;
趋势射线35: DRAWLINE(H=HHV(H,35),H,L=LLV(L,35),L,0),COLORC1005B;
射线35X: DRAWLINE(L=LLV(L,35),L,H=HHV(H,35),L,0),COLORC1005B;
趋势射线49: DRAWLINE(H=HHV(H,49),H,L=LLV(L,49),L,0),COLORYELLOW,LINETHICK2;
射线49X: DRAWLINE(L=LLV(L,49),L,H=HHV(H,49),L,0),COLORYELLOW,LINETHICK2;
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORBLUE,LINETHICK2;
A2:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORBLUE,LINETHICK2;
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1);S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORRED,LINETHICK2;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1);U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORRED,LINETHICK2;
{ Gupang.com 股-旁-网_通达信股票指标公式}
VAR1:=BACKSET(REF(H,2)=HHV(H,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(L,2)=LLV(LOW,5),3);
VAR4:=CROSS(VAR3,0.9);
压力:= REF(H,BARSLAST(VAR2));
STICKLINE(C,REF(H,BARSLAST(VAR2)),REF(H,BARSLAST(VAR2)),1,1),COLOR00CC00,LINETHICK2;
支撑:= REF(L,BARSLAST(VAR4));
STICKLINE(C,REF(LOW,BARSLAST(VAR4)),REF(L,BARSLAST(VAR4)),1,1),COLOR00B4FF,LINETHICK2;

通达信切线主图指标公式

 

相关文章