在线检测未来函数

通达信乘与开方K线主图指标公式

来源:Internet,编辑:股旁网,2012-10-18

GD:=HHV(HIGH,10);
DD:=LLV(LOW,10);
XJ:=GD*DD;
KF:=SQRT(XJ),COLORGREEN,LINETHICK3;
C1:=C>=KF;
C2:=C<KF;
AA:=C1>=C2 ;
BB:=C2>C1 ;
STICKLINE(AA,C,O,3.2,0),COLORRED;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,C,O,3.2,0),COLOR00FF00;
STICKLINE(BB,H,L,0,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.6,0),COLOR0000AA;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.8,0),COLOR0000DD;
STICKLINE(AA,CLOSE,OPEN,1.3,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR777700;
STICKLINE(BB,CLOSE,OPEN,2.6,0),COLORAAAA00;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORBBBB00;
STICKLINE(BB,CLOSE,OPEN,1.8,0),COLORDDDD00;
STICKLINE(BB,CLOSE,OPEN,1.3,0),COLOREEFF00;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
QSX:KF,COLOR00FFFF,LINETHICK3;
IF(C>QSX AND QSX>=REF(QSX,1),QSX ,DRAWNULL),LINETHICK3,COLORRED;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
CCIA:=EMA(EMA(EMA(CCI,2),2),2);
CCIB:=EMA(EMA(EMA(CCI,3),2),2);
X:=(CROSS(CCIA,CCIB) OR (CCIA>=CCIB))
AND CCIA>=-101 AND CCIA>=REF(CCIA,1)
AND REF(CCIA,1)<-101 ;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K1:= EMA(EMA(EMA(K,2),2),2);
D1:= EMA(EMA(EMA(D,2),2),2);
J1:= EMA(EMA(EMA(J,2),2),2);
Y:= J1>REF(J1,1) ;
YJ:=X AND Y ;
DRAWICON(YJ,(LOW * 0.98),13);
{ Gupang.com 股-旁-网_通达信股票指标公式}
DRAWTEXT(YJ,(LOW * 0.97),'买'),COLORYELLOW;
LC5:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC5,0),6,1)/SMA(ABS(CLOSE-LC5),6,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
DA:=SMA(CCC,3,1);
DRAWICON(CROSS(DA,RSI5),H*1.04,15);
DRAWTEXT(CROSS(DA,RSI5),H*1.05,'↙短逃');
DRAWICON(CROSS(80,RSI5),H*1.07,14);
DRAWTEXT(CROSS(80,RSI5),H*1.09,'↙短逃');
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
周15:=FILTER(CROSS(80,RSI1) AND RSI1<REF(RSI1,1),8);
DRAWICON(周15,H*1.12,35);
DRAWTEXT(CROSS(80,RSI5),H*1.11,'↙逃顶');

通达信乘与开方K线主图指标公式

 

相关文章