在线检测未来函数

大智慧成本通道MCST主图指标公式

来源:Internet,编辑:股旁网,2012-10-20

DRAWGBKlast(DATE>900101,strip(RGB(0,0,150),RGB(0,0,40),0));
{以下设置五彩立体K线}
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORff5500;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000033;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
{成本通道}
MCST:DMA(AMOUNT/(100*VOL),VOL/CAPITAL),COLORFF9900,DOTLINE;
{ Gupang.com 股-旁-网_大智慧股票指标公式}
DRAWTEXT(DISPSTATUS=2,MCST,'【市场成本】'),COLOR00ff00,LINETHICK1,ALIGN1;
MCST*1.092 ,COLOR0077ff;
MCST*0.908 ,COLOR00ff00;;
FILLRGN(MCST*1.092,MCST,MCST*1.092>MCST,RGB(60,0,60)),LAYER7;
FILLRGN(MCST*0.908,MCST,MCST*0.908<MCST,RGB(0,60,0)),LAYER7;
{MA5}
MA5:WMA(C,5),Color00FF00,DOTLINE;
PARTLINE(MA5,MA5>REF(MA5,1),rgb(255,150,0)),LINETHICK3,LAYER0;
{高抛.低吸}
RC:=(H+L+C*2)/4;
R2D:=WMA(RC,27);
R2E:=STD(RC,27);
R3F:=(RC-R2D)/R2E*100;
R40:=WMA(R3F,3);
R41:=WMA(R40,3);
JD:=WMA(R41,2);
AJ:=3*R41-2*JD;
DRAWTEXT(CROSS(AJ,JD) ,L-0.05,'←吸'),COLOR00FFFF,LINETHICK2;
DRAWTEXT(CROSS(JD,AJ) ,H+0.05,'←抛'),COLOR0044FF,LINETHICK2;
A:=SUMBARS(V,CAPITAL*1);;{累计换手=100%的周期}
A1:=SUM(COST(10),A)/A;{在A周期里获利10%的平均价}
A2:=SUM(COST(20),A)/A;{在A周期里获利20%的平均价}
A3:=SUM(COST(30),A)/A;{在A周期里获利30%的平均价}
A4:=SUM(COST(40),A)/A;{在A周期里获利40%的平均价}
A5:=SUM(COST(50),A)/A;{在A周期里获利50%的平均价}
庄家成本:(5*A1+4*A2+3*A3+2*A4+A5)/15,COLORff9900, CIRCLEDOT;{求出庄家成本};
DRAWTEXT(DISPSTATUS=2,庄家成本,'【庄家成本】'),COLOR00ffFF,LINETHICK1,ALIGN1;
{E:=LLV(L,250)=L;}{一年中最低价的位置}
{E1:=BARSLAST(E);}{求得一年中最低价的位置到现在的周期}
{选股:IF(CROSS(C,庄家成本) AND E1>=40,1,0 );};{只要40天以上不创一年的新低的都有庄};
DRAWTEXTREL(5,10,'■现实获利盘比例: '+NUMTOSTRN(WINNER(CLOSE)*100,1)+' %'),Color00FFff,LINETHICK3;

大智慧成本通道MCST主图指标公式

 

相关文章