在线检测未来函数

大智慧BOLL金指标公式

来源:Internet,编辑:股旁网,2012-10-21

DRAWGBKlast(c>0,strip(RGB(0,50,0),RGB(0,0,80),1));
{1.重心线}
HH:=HHV(H,3);LL:=LLV(L,3);
ZXC:=WMA((2*C+HH+LL)/4,4);
ZXO:=REF(ZXC,1);
ZXC,COLOR00FF00,LINETHICK2,LAYER0;
PARTLINE(ZXC,ZXC>REF(ZXC,1),rgb(255,80,0)),LINETHICK3,LAYER0;
{2.重心K线--------可以加减大括弧-------}
STICKLINE(ZXO>=ZXC,ZXO,ZXC,9,500 ),COLOR003300,LAYER0;
STICKLINE(ZXO>=ZXC,ZXO,ZXC,6,500 ),COLOR005500,LAYER0;
STICKLINE(ZXO>=ZXC,ZXO,ZXC,3,500 ),COLOR007700,LAYER0;
STICKLINE(ZXO>=ZXC,ZXO,ZXC,1,500 ),COLOR009900,LAYER0;
{ Gupang.com 股-旁-网_大智慧股票指标公式}
STICKLINE(ZXO<ZXC,ZXO,ZXC,9,500 ),COLOR0099FF,LAYER0;
STICKLINE(ZXO<ZXC,ZXO,ZXC,6,500 ),COLOR0077FF,LAYER0;
STICKLINE(ZXO<ZXC,ZXO,ZXC,3,500 ),COLOR0055FF,LAYER0;
STICKLINE(ZXO<ZXC,ZXO,ZXC,1,500 ),COLOR0033FF,LAYER0;
{3.BOLL-金}
MID:MA(ZXC,18),COLOR00FFFF,DOTLINE;
UPPER:MID + 1.8*STD(ZXC,18),COLORFF66FF;
LOWER:MID - 1.8*STD(ZXC,18),COLORFF9900;
{4.高抛.低吸}
RC:=(H+L+C*2)/4;
R2D:=WMA(RC,27);
R2E:=STD(RC,27);
R3F:=(RC-R2D)/R2E*100;
R40:=WMA(R3F,3);
R41:=WMA(R40,3);
JD:=WMA(R41,2);
AJ:=3*R41-2*JD;
DRAWTEXT(CROSS(AJ,JD) ,L-0.2,'←买呗'),COLOR00FFFF,LINETHICK2,LAYER0;
DRAWTEXT(CROSS(JD,AJ) ,H+0.2,'←跑哇'),COLOR00FFFF,LINETHICK2,LAYER0;

大智慧BOLL金指标公式

 

相关文章