在线检测未来函数

通达信四彩K线KDJ主图指标公式

来源:Internet,编辑:股旁网,2012-10-23

零轴:=DYNAINFO(3)*1,COLOR0000FF;
STICKLINE(1,90/100+零轴,90/100+零轴,2,0),COLOR00BBBB;
STICKLINE(1,10/100+零轴,10/100+零轴,2,0),COLOR0000BB;
STICKLINE(1,100/100+零轴,100/100+零轴,2,0),COLORBBBBBB;
STICKLINE(1,50/100+零轴,50/100+零轴,2,0),COLORFF0000;
STICKLINE(1,0/100+零轴,0/100+零轴,2,0),COLORBBBB00;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100+50/100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
KK:=零轴+K/100;
DD:=零轴+D/100;
JJ:=零轴+J/100;
EE:=50/100+零轴;
DRAWBAND(KK,RGB(200,0,150),EE,RGB(0,170,120));
DRAWBAND(JJ,RGB(220,0,0),KK,RGB(120,120,170));
DRAWKLINE(H,O,L,C);
AAA:=JJ>=KK AND KK>=EE;
BBB:=JJ>=KK AND KK<EE;
DDD:=JJ<KK AND KK>=EE;
EEE:=JJ<KK AND KK<EE;
STICKLINE(AAA,H,L,0,0),COLOR0000FF;
STICKLINE(BBB,H,L,0,0),COLORFF00FF;
STICKLINE(DDD,H,L,0,0),COLOR00FFFF;
STICKLINE(EEE,H,L,0,0),COLORFFFF00;
STICKLINE(AAA,CLOSE,OPEN,3.2,0),COLOR000099;
STICKLINE(AAA,CLOSE,OPEN,1.8,0),COLOR0000BB;
STICKLINE(AAA,CLOSE,OPEN,1.3,0),COLOR0000DD;
STICKLINE(AAA,CLOSE,OPEN,0.5,0),COLOR0000FF;
STICKLINE(BBB,CLOSE,OPEN,3.2,0),COLOR990099;
STICKLINE(BBB,CLOSE,OPEN,1.8,0),COLORAA00AA;
STICKLINE(BBB,CLOSE,OPEN,1.3,0),COLORDD00DD;
STICKLINE(BBB,CLOSE,OPEN,0.5,0),COLORFF00FF;
STICKLINE(DDD,C,O,3.2,0),COLOR009999;
STICKLINE(DDD,C,O,2.4,0),COLOR00BBBB;
STICKLINE(DDD,C,O,1.0,0),COLOR00DDDD;
STICKLINE(DDD,C,O,0.6,0),COLOR00FFFF;
STICKLINE(EEE,C,O,3.2,0),COLOR999900;
STICKLINE(EEE,C,O,1.6,0),COLORBBBB00;
STICKLINE(EEE,C,O,1.0,0),COLORDDDD00;
STICKLINE(EEE,C,O,0.5,0),COLORFFFF00;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
SELL2:=(CROSS(88,RSI1));
DRAWTEXT(SELL2,HIGH*1.02,'←卖'),COLOR00FF00;
VB1:=C-REF(C,1);
VB2:=100*EMA(EMA(VB1,6),6)/EMA(EMA(ABS(VB1),6),6);
VB3:=IF(LLV(VB2,2)=LLV(VB2,7) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
DRAWTEXT(VB4,LOW*0.98,'←买'),COLOR00FFFF;
DRAWTEXT_FIX(1,0,0,0,HYBLOCK);
{ Gupang.com 股-旁-网_通达信股票指标公式}
威廉波段:=100-(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100;
威廉风险:=IF(威廉波段>95,(100/100+零轴)-(100/100+零轴)*0.009,100/100+零轴),COLOR00FFFF,LINETHICK0;
DRAWBAND(100/100+零轴,RGB(220,220,0),威廉风险,RGB(0,0,0));
WLDB:=IF(威廉波段<5,(0/100+零轴)+(0/100+零轴)*0.009,0/100+零轴),COLORFFFF00,LINETHICK1;
DRAWBAND(WLDB,RGB(0,220,220),0/100+零轴,RGB(0,0,0));
DRAWTEXT_FIX(1,0.05,0.0,0,'【彩色K线标识】★★红色柱---J大于K并在中轴上★★黄色柱--J小于K并在中轴上★★ '),COLORFFFFFF;
DRAWTEXT_FIX(1,0.05,0.035,0,'【彩色K线标识】★★粉色柱---J大于K并在中轴下★★青色柱--J小于K并在中轴下★★ '),COLOR00FFFF;
DRAWTEXT_FIX(1,0.05,0.07,0,'【彩色三角型标识】★★青色三角形---威廉底部★★黄色三角形--威廉顶部★★ '),COLORFFFF00;

通达信四彩K线KDJ主图指标公式

 

相关文章