在线检测未来函数

通达信主力控盘+CCI指标公式

来源:Internet,编辑:股旁网,2012-10-31

NOTEXT1:-100,COLORGRAY,DOTLINE;
NOTEXT2:100,COLORGRAY,DOTLINE;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,5))/(0.015*AVEDEV(TYP,5))LINETHICK1,COLORYELLOW;
{STICKLINE(CCI1>100,CCI1,100,4,0),COLOR00CC66;
STICKLINE(CCI1<-100,CCI1,-100,4,0),COLORCC00EE;
CCI:CCI1,LINETHICK1,COLORYELLOW;}
VAR1:=EMA(EMA(CLOSE,3),1);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
A10:=CROSS(控盘,0);
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLOR0000FF,NODRAW;
有庄控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
无庄控盘:IF(控盘<0,控盘,0),COLORFF6600,NODRAW;
开始控盘:IF(A10,5,0),LINETHICK3,COLORYELLOW,NODRAW;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
个股:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLORBROWN,NODRAW;
短线反弹:IF(CROSS(个股,9),80,0),STICK,LINETHICK3,COLORLIBLUE;
DRAWTEXT(CROSS(个股,9),75,'●反弹'),COLORLIBLUE;
STICKLINE(控盘<0,控盘,0,3.5,0),COLORFF3300;
STICKLINE(控盘<0,控盘,0,2.5,0),COLORFF6600;
STICKLINE(控盘<0,控盘,0,1.5,0),COLORFF8800;
STICKLINE(控盘<0,控盘,0,0.5,0),COLORFFAA00;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR000033;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR000066;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR000099;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,0.5,0),COLOR0000CC;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘*0.8,0,3.0,0),COLORFF0066;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘*0.8,0,2.0,0),COLORFF0099;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘*0.8,0,1.5,0),COLORFF00BB;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘*0.8,0,0.5,0),COLORFF00FF;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR005500;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR008800;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR00BB00;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,0.5,0),COLOR00EE00;
STICKLINE(A10,控盘,0,3.5,0),COLOR0066FF;
STICKLINE(A10,控盘,0,2.5,0),COLOR0099FF;
STICKLINE(A10,控盘,0,1.0,0),COLOR00CCFF;
STICKLINE(A10,控盘,0,0.5,0),COLOR00FFFF;

通达信主力控盘+CCI指标公式

 

相关文章