在线检测未来函数

大智慧预测量指标公式

来源:Internet,编辑:股旁网,2012-11-06

input:m1(5),m2(10),m3(20);
MA5:=MA(VOL,M1);
MA10:=MA(VOL,M2);
MA20:=MA(VOL,M3);
交易分钟数:=if(CURRENTTIME>93000 and CURRENTTIME<150000,
if(CURRENTTIME<113000,(TIMETOT0(CURRENTTIME)-34200)/60,
if(CURRENTTIME>130000,(TIMETOT0(CURRENTTIME)-39600)/60,120)),240);
预测量1:=IF(BARSTATUS=2,VOL/交易分钟数*240,VOL);
成交量:VOL,COLORRED,LINETHICK0;
预测量:if(DYNAINFO(4)=0,v,预测量1),COLORYELLOW,LINETHICK0;
STICKLINE(BARSTATUS=2,0,预测量,9,1),COLOR00FFFF,DOTLINE,LAYER7;
DRAWICON(cross(ma5,ma10) AND cross(ma5,ma20),ma5,7),LAYER0;
天量A:=IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,SUMBARS(VOL,CAPITAL))*3);
地量A:=IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,SUMBARS(VOL,CAPITAL))/3);
天量:IF(天量A,888,0),COLORFF00FF,LINETHICK0;
地量:IF(地量A,888,0),COLORBLUE,LINETHICK0;
倍量:IF(VOL>REF( VOL,1)*2,888,0),COLORFF75FF,LINETHICK0;
梯量:IF(COUNT(V>REF(V,1),3)=3 AND COUNT(C>O,3)=3,888,0),COLOR824173,LINETHICK0;
倍缩:IF(V<=REF(V,1)*0.5,888,0),COLORWHITE,LINETHICK0;
STICKLINE(天量,VOL,0,9,0),COLORFF00FF;
STICKLINE(地量,VOL,0,9,0),COLORBLUE;
STICKLINE(倍量,VOL,0,9,0),COLORFF75FF;
STICKLINE(梯量,VOL,0,9,0),COLOR824173;
STICKLINE(倍缩,VOL,0,9,0),COLORWHITE;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
STICKLINE(DIF>DEA,0,VOL,8,0),COLORRED;
STICKLINE(DIF<DEA,0,VOL,8,0),COLORCYAN;
N1:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
STICKLINE(J>D,VOL/2,VOL,8,0),COLORYELLOW;
STICKLINE(J<D,VOL/2,VOL,8,0),COLOR008800;
STICKLINE(V>=2*REF(V,1),V/2,V/2,10,0),COLORFF00FF;

大智慧预测量指标公式

 

相关文章